|
| CRhinoInferredCurveArray () |
|
| ~CRhinoInferredCurveArray () |
|
void | Append (const CRhinoInferredCurve &c) |
|
| ON_ClassArray () ON_NOEXCEPT |
| construction //////////////////////////////////////////////////////// More...
|
|
| ON_ClassArray (const ON_ClassArray< CRhinoInferredCurve > &) |
| Copy constructor. More...
|
|
| ON_ClassArray (size_t) |
| size_t parameter = initial capacity More...
|
|
virtual | ~ON_ClassArray () |
| override for struct member deallocation, etc. More...
|
|
void | Append (const CRhinoInferredCurve &) |
|
void | Append (int, const CRhinoInferredCurve *) |
| Append copy of an array T[count]. More...
|
|
CRhinoInferredCurve & | AppendNew () |
| array operations //////////////////////////////////////////////////// More...
|
|
CRhinoInferredCurve * | Array () |
| The Array() function return the. More...
|
|
const CRhinoInferredCurve * | Array () const |
| m_a pointer value. More...
|
|
CRhinoInferredCurve * | At (int) |
| At(index) returns nullptr if index < 0 or index >= count. More...
|
|
const CRhinoInferredCurve * | At (int) const |
|
CRhinoInferredCurve * | At (ON__INT64) |
|
const CRhinoInferredCurve * | At (ON__INT64) const |
|
CRhinoInferredCurve * | At (ON__UINT64) |
|
const CRhinoInferredCurve * | At (ON__UINT64) const |
|
CRhinoInferredCurve * | At (unsigned int) |
|
const CRhinoInferredCurve * | At (unsigned int) const |
|
int | BinarySearch (const CRhinoInferredCurve *, int(*)(const CRhinoInferredCurve *, const CRhinoInferredCurve *)) const |
| See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
|
|
int | BinarySearch (const CRhinoInferredCurve *, int(*)(const CRhinoInferredCurve *, const CRhinoInferredCurve *), int) const |
|
int | Capacity () const |
| capacity of array More...
|
|
int | Count () const |
| query /////////////////////////////////////////////////////////////// More...
|
|
void | Destroy () |
| onfree any memory and set count and capacity to zero More...
|
|
void | EmergencyDestroy (void) |
| emergency bailout /////////////////////////////////////////////////// More...
|
|
void | Empty () |
| Sets count to 0, leaves capacity untouched. More...
|
|
CRhinoInferredCurve * | First () |
|
const CRhinoInferredCurve * | First () const |
| returns nullptr if count = 0 More...
|
|
virtual bool | HeapSort (int(*)(const CRhinoInferredCurve *, const CRhinoInferredCurve *)) |
| QuickSort() is generally the better choice. More...
|
|
void | Insert (int, const CRhinoInferredCurve &) |
| Insert called with a reference uses operator =. More...
|
|
int | InsertInSortedList (const CRhinoInferredCurve &, int(*)(const CRhinoInferredCurve *, const CRhinoInferredCurve *)) |
|
int | InsertInSortedList (const CRhinoInferredCurve &, int(*)(const CRhinoInferredCurve *, const CRhinoInferredCurve *), int) |
|
CRhinoInferredCurve * | KeepArray () |
|
CRhinoInferredCurve * | Last () |
|
const CRhinoInferredCurve * | Last () const |
| returns nullptr if count = 0 More...
|
|
int | NewCapacity () const |
|
| operator const CRhinoInferredCurve * () const |
|
| operator CRhinoInferredCurve * () |
| The cast operators return a pointer. More...
|
|
ON_ClassArray< CRhinoInferredCurve > & | operator= (const ON_ClassArray< CRhinoInferredCurve > &) |
| Assignment operator. More...
|
|
CRhinoInferredCurve & | operator[] (int) |
|
const CRhinoInferredCurve & | operator[] (int) const |
|
CRhinoInferredCurve & | operator[] (ON__INT64) |
|
const CRhinoInferredCurve & | operator[] (ON__INT64) const |
|
CRhinoInferredCurve & | operator[] (ON__UINT64) |
|
const CRhinoInferredCurve & | operator[] (ON__UINT64) const |
|
CRhinoInferredCurve & | operator[] (unsigned int) |
|
const CRhinoInferredCurve & | operator[] (unsigned int) const |
|
bool | Permute (const int *) |
|
virtual bool | QuickSort (int(*)(const CRhinoInferredCurve *, const CRhinoInferredCurve *)) |
| Sorts the array using the heap sort algorithm. More...
|
|
virtual CRhinoInferredCurve * | Realloc (CRhinoInferredCurve *, int) |
| low level memory management /////////////////////////////////////// More...
|
|
void | Remove () |
|
void | Remove (int) |
|
CRhinoInferredCurve * | Reserve (size_t) |
| memory management ///////////////////////////////////////////////// More...
|
|
void | Reverse () |
| reverse order More...
|
|
int | Search (const CRhinoInferredCurve *, int(*)(const CRhinoInferredCurve *, const CRhinoInferredCurve *)) const |
|
void | SetArray (CRhinoInferredCurve *) |
|
void | SetArray (CRhinoInferredCurve *, int, int) |
|
CRhinoInferredCurve * | SetCapacity (size_t) |
|
void | SetCount (int) |
| low level memory management ////////////////////////////////////////// More...
|
|
void | Shrink () |
| remove unused capacity More...
|
|
unsigned int | SizeOfArray () const |
| amount of memory in the m_a[] array More...
|
|
unsigned int | SizeOfElement () const |
| amount of memory in an m_a[] array element More...
|
|
bool | Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const CRhinoInferredCurve *, const CRhinoInferredCurve *)) const |
|
bool | Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const CRhinoInferredCurve *, const CRhinoInferredCurve *, void *), void *) const |
|
void | Swap (int, int) |
| swap elements i and j More...
|
|
unsigned int | UnsignedCount () const |
|
void | Zero () |
|