Rhino C++ API
8.13
|
#include <RhinoSdkUiProgressBar.h>
Public Member Functions | |
CRhinoUiProgressBar (HWND hMainWnd, const char *lpMessage, int nSize=100, int nMaxValue=100, bool bShow=false, int nPane=0) | |
CRhinoUiProgressBar (HWND hMainWnd, const wchar_t *lpMessage, int nSize=100, int nMaxValue=100, bool bShow=false, int nPane=0) | |
CRhinoUiProgressBar (HWND hMainWnd=NULL) | |
virtual | ~CRhinoUiProgressBar () |
void | Clear () |
Clears the progress bar control and restores the status bar. More... | |
bool | Create (const char *lpMessage, int nSize=100, int nMaxValue=100, bool bShow=false, int nPane=0) |
bool | Create (const wchar_t *lpMessage, int nSize=100, int nMaxValue=100, bool bShow=false, int nPane=0) |
afx_msg BOOL32 | OnEraseBkgnd (CDC *pDC) |
bool | SetMessage (const char *lpMessage) |
Sets the message to display to left of control. More... | |
bool | SetMessage (const wchar_t *lpMessage) |
bool | SetSize (int nSize) |
Sets the size of the progress bar control. More... | |
Public Member Functions inherited from CRhinoUiProgressCtrl | |
CRhinoUiProgressCtrl () | |
virtual | ~CRhinoUiProgressCtrl () |
COLORREF | GetBkColor () |
Sets the text visibility. More... | |
COLORREF | GetForeColor () |
Get an set the background color. More... | |
CString | GetText () |
Advances the current position by a specified increment. More... | |
COLORREF | GetTextBkColor () |
Get an set the foreground color. More... | |
COLORREF | GetTextForeColor () |
Get an set the text background color. More... | |
int | OffsetPos (int nPos) |
Advances the current position by a step. More... | |
afx_msg BOOL32 | OnEraseBkgnd (CDC *pDC) |
afx_msg LRESULT | OnGetText (WPARAM, LPARAM) |
afx_msg void | OnPaint () |
afx_msg LRESULT | OnSetText (WPARAM, LPARAM) |
afx_msg void | OnSize (UINT nType, int cx, int cy) |
void | SetBkColor (COLORREF cf) |
void | SetForeColor (COLORREF cf) |
int | SetPos (int nPos) |
Sets the step increment. More... | |
void | SetRange (int nLower, int nUpper) |
void | SetShowStyle (int nStyle) |
Sets the text font. More... | |
void | SetShowText (bool bShow) |
Sets the text display style. More... | |
int | SetStep (int nStep) |
Sets the lower and upper range. More... | |
void | SetText (LPCTSTR lpText) |
void | SetTextBkColor (COLORREF cf) |
BOOL32 | SetTextFont (const LOGFONT &lf) |
Gets and sets the text. More... | |
void | SetTextForeColor (COLORREF cf) |
int | StepIt () |
Sets the position. More... | |
Protected Member Functions | |
bool | _Create (LPCTSTR lpMessage, int nSize=100, int nMaxValue=100, bool bShow=false, int nPane=0) |
CStatusBar * | GetStatusBar () |
Retrieves a pointer to the status bar. More... | |
bool | Resize () |
Called when the progress bar needs to be resized. More... | |
Protected Attributes | |
int | m_nPane |
ID of status bar pane progress bar will appear in. More... | |
int | m_nSize |
Percentage size of control. More... | |
CWnd * | m_pMainWnd |
Pointer to main window. More... | |
CRect | m_Rect |
Dimensions of the whole thing. More... | |
CString | m_strMessage |
Message to display to left of control. More... | |
CString | m_strPrevText |
Previous text in status bar. More... | |
Protected Attributes inherited from CRhinoUiProgressCtrl | |
bool | m_bShowText |
Text visibility. More... | |
COLORREF | m_cfBackground |
Background color. More... | |
COLORREF | m_cfForeground |
Foreground color. More... | |
COLORREF | m_cfTextBackground |
Text background color. More... | |
COLORREF | m_cfTextForeground |
Text foreground color. More... | |
CFont | m_Font |
Text font. More... | |
int | m_nBarWidth |
Vidth of the progress bar. More... | |
int | m_nMax |
Maximum range value. More... | |
int | m_nMin |
Minimum range value. More... | |
int | m_nPos |
Current position. More... | |
int | m_nShowStyle |
Text show style. More... | |
int | m_nStepSize |
Step increment. More... | |
CString | m_strText |
Progress bar text. More... | |
Additional Inherited Members | |
Public Types inherited from CRhinoUiProgressCtrl | |
enum | display_mode { display_test = 1, display_percent = 2, display_text_and_percent = 3, force_32bit_display_mode = 0xFFFFFFFF } |
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
CRhinoUiProgressBar::CRhinoUiProgressBar | ( | HWND | hMainWnd = NULL | ) |
CRhinoUiProgressBar::CRhinoUiProgressBar | ( | HWND | hMainWnd, |
const char * | lpMessage, | ||
int | nSize = 100 , |
||
int | nMaxValue = 100 , |
||
bool | bShow = false , |
||
int | nPane = 0 |
||
) |
CRhinoUiProgressBar::CRhinoUiProgressBar | ( | HWND | hMainWnd, |
const wchar_t * | lpMessage, | ||
int | nSize = 100 , |
||
int | nMaxValue = 100 , |
||
bool | bShow = false , |
||
int | nPane = 0 |
||
) |
|
virtual |
|
protected |
void CRhinoUiProgressBar::Clear | ( | ) |
Clears the progress bar control and restores the status bar.
bool CRhinoUiProgressBar::Create | ( | const char * | lpMessage, |
int | nSize = 100 , |
||
int | nMaxValue = 100 , |
||
bool | bShow = false , |
||
int | nPane = 0 |
||
) |
bool CRhinoUiProgressBar::Create | ( | const wchar_t * | lpMessage, |
int | nSize = 100 , |
||
int | nMaxValue = 100 , |
||
bool | bShow = false , |
||
int | nPane = 0 |
||
) |
|
protected |
Retrieves a pointer to the status bar.
afx_msg BOOL32 CRhinoUiProgressBar::OnEraseBkgnd | ( | CDC * | pDC | ) |
|
protected |
Called when the progress bar needs to be resized.
bool CRhinoUiProgressBar::SetMessage | ( | const char * | lpMessage | ) |
Sets the message to display to left of control.
bool CRhinoUiProgressBar::SetMessage | ( | const wchar_t * | lpMessage | ) |
bool CRhinoUiProgressBar::SetSize | ( | int | nSize | ) |
Sets the size of the progress bar control.
|
protected |
ID of status bar pane progress bar will appear in.
|
protected |
Percentage size of control.
|
protected |
Pointer to main window.
|
protected |
Dimensions of the whole thing.
|
protected |
Message to display to left of control.
|
protected |
Previous text in status bar.