Rhino C++ API
8.13
|
Namespaces | |
RhinoTabbedDockBar | |
Typedefs | |
typedef struct tagRhinoUiOptionsListCtrlNM * | LPRhinoUiOptionsListCtrlNM |
typedef struct tagRhinoUiOptionsListCtrlNM | RhinoUiOptionsListCtrlNM |
Functions | |
RHINO_SDK_FUNCTION CRhinoUiPaintManager::DrawExpanderHeaderOptions | operator& (CRhinoUiPaintManager::DrawExpanderHeaderOptions a, CRhinoUiPaintManager::DrawExpanderHeaderOptions b) |
RHINO_SDK_FUNCTION CRhinoUiPaintManager::DrawExpanderHeaderOptions & | operator&= (CRhinoUiPaintManager::DrawExpanderHeaderOptions &a, CRhinoUiPaintManager::DrawExpanderHeaderOptions b) |
RHINO_SDK_FUNCTION CRhinoUiPaintManager::DrawExpanderHeaderOptions | operator| (CRhinoUiPaintManager::DrawExpanderHeaderOptions a, CRhinoUiPaintManager::DrawExpanderHeaderOptions b) |
RHINO_SDK_FUNCTION CRhinoUiPaintManager::DrawExpanderHeaderOptions & | operator|= (CRhinoUiPaintManager::DrawExpanderHeaderOptions &a, CRhinoUiPaintManager::DrawExpanderHeaderOptions b) |
RHINO_SDK_FUNCTION CRhinoUiPaintManager::DrawExpanderHeaderOptions | operator~ (CRhinoUiPaintManager::DrawExpanderHeaderOptions a) |
RHINO_SDK_FUNCTION COLORREF | RhGetDialogBackgroundColor (HWND ctrl) |
RHINO_UILIB_DEFINE_GUID (RHINO_CLASH_DOCK_BAR_ID, 0x770ff06a, 0xd775, 0x41e4, 0xbb, 0xc7, 0x9f, 0x32, 0xed, 0x18, 0x9b, 0x5e) | |
RHINO_UILIB_DEFINE_GUID (RHINO_COMMAND_DOCK_BAR_ID, 0x1D3D1785, 0x2332, 0x428B, 0xA8, 0x38, 0xB2, 0xFE, 0x39, 0xEC, 0x50, 0xF4) | |
RHINO_UILIB_DEFINE_GUID (RHINO_CONTOUR_ANALYSIS_DOCK_BAR_ID, 0xa0f238df, 0x1898, 0x47cf, 0x91, 0x9d, 0xf8, 0x4d, 0xe9, 0x5a, 0x0b, 0xb9) | |
RHINO_UILIB_DEFINE_GUID (RHINO_CURVATURE_ANALYSIS_DOCK_BAR_ID, 0x948D3151, 0x91AA, 0x4959, 0xAD, 0x67, 0xBD, 0x49, 0xFB, 0xB2, 0x48, 0x79) | |
RHINO_UILIB_DEFINE_GUID (RHINO_CURVATURE_GRAPH_DOCK_BAR_ID, 0x54D560F5, 0xC1B2, 0x4BBA, 0x95, 0x34, 0x3C, 0x00, 0xE4, 0x0D, 0x30, 0x57) | |
RHINO_UILIB_DEFINE_GUID (RHINO_DIRECTION_ANALYSIS_DOCK_BAR_ID, 0x9a0a0262, 0x6e97, 0x4bb6, 0xa9, 0xc, 0x4f, 0xd7, 0x93, 0x1, 0xd6, 0x77) | |
RHINO_UILIB_DEFINE_GUID (RHINO_DOCKBARTAB_LAYER, 0x3610bf83, 0x047d, 0x4f7f, 0x93, 0xfd, 0x16, 0x3e, 0xa3, 0x05, 0xb4, 0x93) | |
RHINO_UILIB_DEFINE_GUID (RHINO_DOCKBARTAB_PROPERTIES, 0x34ffb674, 0xc504, 0x49d9, 0x9f, 0xcd, 0x99, 0xcc, 0x81, 0x1d, 0xcd, 0xa2) | |
RHINO_UILIB_DEFINE_GUID (RHINO_DRAFT_ANGLE_DOCK_BAR_ID, 0xF814F8D8, 0xEEC0, 0x46FD, 0x85, 0x85, 0xE0, 0xE8, 0x48, 0x6A, 0xB8, 0x4D) | |
RHINO_UILIB_DEFINE_GUID (RHINO_DRAFT_ANGLE_ETO_DOCK_BAR_ID, 0xFE0CBB9E, 0x336B, 0x4482, 0x9A, 0xBE, 0xB9, 0x4B, 0x35, 0xB0, 0x08, 0xFD) | |
RHINO_UILIB_DEFINE_GUID (RHINO_DRAG_STRENGTH_DOCK_BAR_ID, 0x50eb6c7b, 0xbe0, 0x4166, 0xad, 0x17, 0xea, 0x69, 0x4c, 0x97, 0xa6, 0xf4) | |
RHINO_UILIB_DEFINE_GUID (RHINO_EDGE_ANALYSIS_DOCK_BAR_ID, 0xC9FB93D6, 0xC1AB, 0x4464, 0xAD, 0x3A, 0xED, 0x2A, 0x8B, 0xC1, 0x20, 0x9B) | |
RHINO_UILIB_DEFINE_GUID (RHINO_EDGE_CONTINUITY_DOCK_BAR_ID, 0xf7cda9c5, 0xa66c, 0x4ae6, 0x87, 0xb5, 0x89, 0xc2, 0x42, 0x54, 0xe3, 0xb3) | |
RHINO_UILIB_DEFINE_GUID (RHINO_EMAP_DOCK_BAR_ID, 0xCA1753B1, 0xAE23, 0x4880, 0xAD, 0x93, 0x39, 0xB5, 0x29, 0x95, 0x22, 0xE6) | |
RHINO_UILIB_DEFINE_GUID (RHINO_END_ANALYSIS_DOCK_BAR_ID, 0x4c2d9eed, 0xbc64, 0x48ba, 0xb9, 0x10, 0x40, 0xa0, 0xe6, 0x5c, 0xa, 0xe3) | |
RHINO_UILIB_DEFINE_GUID (RHINO_OSNAP_DOCK_BAR_ID, 0xd3c4a392, 0x88de, 0x4c4f, 0x88, 0xa4, 0xba, 0x56, 0x36, 0xef, 0x7f, 0x38) | |
RHINO_UILIB_DEFINE_GUID (RHINO_SELECTION_FILTER_DOCK_BAR_ID, 0x918191ca, 0x1105, 0x43f9, 0xa3, 0x4a, 0xdd, 0xa4, 0x27, 0x68, 0x83, 0xc1) | |
RHINO_UILIB_DEFINE_GUID (RHINO_THICKNESS_DISP_DOCK_BAR_ID, 0xc0c9e0f1, 0xd554, 0x453b, 0x87, 0x12, 0xa0, 0x20, 0xac, 0xe0, 0xb8, 0xe4) | |
RHINO_UILIB_DEFINE_GUID (RHINO_UI_FILE_CLOSED_EVENT, 0x2395e5fc, 0xdf89, 0x49bd, 0xa6, 0xee, 0x2e, 0xe0, 0x0, 0x10, 0x24, 0xb5) | |
RHINO_UILIB_DEFINE_GUID (RHINO_UI_FILE_MACRO_DELETE_EVENT, 0x221ecf6b, 0xe12, 0x4a3b, 0xae, 0x4b, 0x91, 0xe4, 0xde, 0x75, 0xa, 0x5f) | |
RHINO_UILIB_DEFINE_GUID (RHINO_UI_FILE_MACRO_MODIFIED_EVENT, 0x7f30da3f, 0x54cb, 0x4964, 0xbf, 0xff, 0xf, 0x28, 0x79, 0x87, 0x6f, 0x85) | |
RHINO_UILIB_DEFINE_GUID (RHINO_UI_FILE_MACRO_NEW_EVENT, 0x498d441f, 0x66, 0x48ab, 0x87, 0xd, 0x7c, 0xcc, 0x4b, 0x34, 0x10, 0xa3) | |
RHINO_UILIB_DEFINE_GUID (RHINO_UI_FILE_OPEN_EVENT, 0x5fa9bc7f, 0xd8ef, 0x40fd, 0x91, 0xf4, 0x57, 0xcf, 0xf2, 0x22, 0xcd, 0xe2) | |
CRhinoUiFileEvent Event Id's. More... | |
RHINO_UILIB_DEFINE_GUID (RHINO_VIEW_MANAGER_DOCK_BAR_ID, 0x844b3278, 0xe78e, 0x4844, 0x86, 0x8d, 0x63, 0x9b, 0x9b, 0x65, 0x46, 0x50) | |
RHINO_UILIB_DEFINE_GUID (RHINO_ZEBRA_DOCK_BAR_ID, 0x36EF80FE, 0x7D51, 0x41EE, 0x80, 0x44, 0xF1, 0x7B, 0x10, 0x73, 0x09, 0xCB) | |
RHINO_SDK_FUNCTION ON_FileReference | RhinoGetDibAsTextureFileReference (const CRhinoDib &dib, ON__UINT32 crc) |
RHINO_SDK_FUNCTION bool | RhinoOnToolBarButtonClicked (const wchar_t *lpsMacro, const wchar_t *lpsTooltip) |
RHINO_SDK_FUNCTION int | RhinoRoundOff (double x) |
void * | RHINOUI_DIB_CALLOC (size_t num, size_t size) |
void | RHINOUI_DIB_FREE (void *memblock) |
void * | RHINOUI_DIB_MALLOC (size_t size) |
RHINO_SDK_FUNCTION void | RhinoUiAddTabFactory (CRhinoUiPanelFactory *pFactory) |
RHINO_SDK_FUNCTION void | RhinoUiCloseDockbarTab (const CRhinoDoc &doc, const ON_UUID &uuidTabId, const ON_UUID *uuidDockBar=nullptr) |
void RHINO_SDK_FUNCTION | RhinoUiColorComboBoxItemDataInit (RhinoUiColorComboBoxItemData &data) |
RHINO_SDK_FUNCTION bool | RhinoUiColorDialog (CWnd *pWndParent, ON_Color &color, bool include_button_colors=false, const wchar_t *dialog_title=NULL) |
RHINO_SDK_FUNCTION void | RhinoUiCreateTabQuietly (const CRhinoDoc &doc, const ON_UUID &uuidTabId) |
void | RhinoUiDibInstallMemManager (void *(*my_calloc)(size_t num, size_t size), void *(*my_malloc)(size_t size), void(*my_free)(void *memblock)) |
RHINO_SDK_FUNCTION CRhinoUiDockBar * | RhinoUiDockBarForTab (const CRhinoDoc &doc, const ON_UUID &uuidTabId) |
RHINO_SDK_FUNCTION CRhinoUiDockBarManager & | RhinoUiDockBarManager () |
RHINO_SDK_FUNCTION void | RhinoUiDockBarsForTab (const CRhinoDoc &doc, const ON_UUID &uuidTabId, ON_SimpleArray< CRhinoUiDockBar * > &dockbars) |
RHINO_SDK_FUNCTION void | RhinoUiDockBarsForTab (const CRhinoDoc &doc, const ON_UUID &uuidTabId, ON_SimpleArray< ON_UUID > &dockbars) |
RHINO_SDK_FUNCTION void | RhinoUiDockBarsForTab (const ON_UUID &uuidTabId, ON_SimpleArray< CRhinoUiDockBar * > &dockbars) |
Use this function only when uuidTabId refers to a panel without document context. More... | |
RHINO_SDK_FUNCTION CRhinoUiDockBarTab * | RhinoUiDockBarTabFromId (const CRhinoDoc &doc, const ON_UUID &uuidTabId) |
RHINO_SDK_FUNCTION void | RhinoUiDockBarTabsFromId (const CRhinoDoc &doc, const ON_UUID &uuidTabId, ON_SimpleArray< CRhinoUiDockBarTab * > &dockbartabs) |
RHINO_SDK_FUNCTION void | RhinoUiDockBarTabUpdateIcon (const CRhinoDoc &doc, const ON_UUID &uuidTabId) |
RHINO_SDK_FUNCTION void | RhinoUiEnableTabFactory (const ON_UUID &uuidTabId, bool b) |
void RHINO_SDK_FUNCTION | RhinoUiFontComboBoxItemDataInit (RhinoUiFontComboBoxItemData &data) |
RHINO_SDK_FUNCTION bool | RhinoUiIsDisabledTabbedDockBar (CControlBar *) |
RHINO_SDK_FUNCTION bool | RhinoUiIsTabFactoryEnabled (const ON_UUID &uuidTabId) |
RHINO_SDK_FUNCTION bool | RhinoUiIsTabVisible (const CRhinoDoc &doc, const ON_UUID &uuidTabId, bool bIsSelectedTab=true) |
void RHINO_SDK_FUNCTION | RhinoUiLayerComboBoxItemDataInit (RhinoUiLayerComboBoxItemData &data) |
UINT | RhinoUiLayerListCtrlColumnClickMessageId () |
void RHINO_SDK_FUNCTION | RhinoUiLinetypeComboBoxItemDataInit (RhinoUiLinetypeComboBoxItemData &data) |
RHINO_SDK_FUNCTION CFrameWnd * | RhinoUiMainFrame () |
RHINO_SDK_FUNCTION HWND | RhinoUiMainFrameHWND () |
RHINO_SDK_FUNCTION CRhinoUiManager & | RhinoUiManager () |
RHINO_SDK_FUNCTION CRhinoUiModlessDockingDialogManager & | RhinoUiModlessDockingDialogManager () |
RHINO_SDK_FUNCTION AFX_MODULE_STATE * | RhinoUiModuleState () |
RHINO_SDK_FUNCTION CRhinoUiDockBar * | RhinoUiOpenDockbarTab (const CRhinoDoc &doc, const ON_UUID &uuidTabId, bool makeSelectedTab=true, const ON_UUID *uuidDockBar=nullptr) |
RHINO_SDK_FUNCTION CRhinoUiDockBar * | RhinoUiOpenDockbarTab (const ON_UUID &uuidTabId, bool makeSelectedTab=true, const ON_UUID *uuidDockBar=nullptr) |
RHINO_SDK_FUNCTION CRhinoUiPageDockBarManager & | RhinoUiPageDockBarManager () |
RHINO_SDK_FUNCTION CRhinoUiPaintManager & | RhinoUiPaintManager () |
RHINO_SDK_FUNCTION void | RhinoUiPanelFactories (ON_SimpleArray< const CRhinoUiPanelFactory * > &factories) |
const RHINO_SDK_FUNCTION CRhinoUiPanelFactory * | RhinoUiPanelFactoryFromId (const ON_UUID &id) |
void RHINO_SDK_FUNCTION | RhinoUiPrintWidthComboBoxItemDataInit (RhinoUiPrintWidthComboBoxItemData &data) |
RHINO_SDK_FUNCTION void | RhinoUiRegisteredDockbarTabs (ON_SimpleArray< ON_UUID > &aTabIds) |
RHINO_SDK_FUNCTION CRhinoUiResourceManager & | RhinoUiResourceManager () |
RHINO_SDK_FUNCTION bool | RhinoUiScaleLocalizedFonts () |
RHINO_SDK_FUNCTION bool | RhinoUiScaleLocalizedFonts (UINT &nSize) |
RHINO_SDK_FUNCTION void | RhinoUiShowDockbarTab (const CRhinoDoc &doc, const ON_UUID &uuidTabId, bool bShow, bool bMakeSelected, const ON_UUID *uuidDockBar=nullptr) |
RHINO_SDK_FUNCTION void | RhinoUiShowDockbarTab (const CRhinoDoc &doc, const ON_UUID &uuidTabId, bool bShow, const ON_UUID *uuidDockBar=nullptr) |
RHINO_SDK_FUNCTION void | RhinoUiTabHostIds (const CRhinoDoc &doc, const ON_UUID &panelId, ON_SimpleArray< ON_UUID > &hostIds) |
Variables | |
RHINO_SDK_DATA UUID | uuidPanelContextHelp |
RHINO_SDK_DATA UUID | uuidPanelDisplay |
RHINO_SDK_DATA UUID | uuidPanelEnvironments |
RHINO_SDK_DATA UUID | uuidPanelFileExplorer |
RHINO_SDK_DATA UUID | uuidPanelGroundPlane |
RHINO_SDK_DATA UUID | uuidPanelLayers |
RHINO_SDK_DATA UUID | uuidPanelLibraries |
RHINO_SDK_DATA UUID | uuidPanelLightManager |
RDK panels. More... | |
RHINO_SDK_DATA UUID | uuidPanelMaterials |
RHINO_SDK_DATA UUID | uuidPanelNotes |
RHINO_SDK_DATA UUID | uuidPanelObjectProps |
RHINO_SDK_DATA UUID | uuidPanelRenderSettings |
RHINO_SDK_DATA UUID | uuidPanelSun |
RHINO_SDK_DATA UUID | uuidPanelTextures |
#define CRhinoUiCheckListBox CCheckListBox |
if defined (ON_OS_WINDOWS)
#define CRhinoUiListBox CListBox |
RhinoSdkUiCheckListBox.h
#define CRmaDib CRhinoDib |
RmaDib specific
#define CRmaUiBitmapButton CRhinoUiBitmapButton |
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
Map old clas names to new ones
#define CRmaUiCheckBox CRhinoUiCheckBox |
#define CRmaUiColorButton CRhinoUiColorButton |
#define CRmaUiColorComboBox CRhinoUiColorComboBox |
#define CRmaUiColorComboBoxItem CRhinoUiColorComboBoxItem |
#define CRmaUiColorListBox CRhinoUiColorListBox |
#define CRmaUiDialog CRhinoUiDialog |
#define CRmaUiDialogItemResizer CRhinoUiDialogItemResizer |
#define CRmaUiDialogSub CRhinoUiDialogSub |
#define CRmaUiDirDialog CRhinoUiDirDialog |
#define CRmaUiEditInt CRhinoUiEditInt |
#define CRmaUiEditReal CRhinoUiEditReal |
#define CRmaUiFontComboBox CRhinoUiFontComboBox |
#define CRmaUiGradientSlider CRhinoUiGradientSliderCtrl |
#define CRmaUiGridListCombo CRhinoUiGridListCombo |
#define CRmaUiGridListCtrl CRhinoUiGridListCtrl |
#define CRmaUiGridListEdit CRhinoUiGridListEdit |
#define CRmaUiGridListHeaderCtrl CRhinoUiGridListHeaderCtrl |
#define CRmaUiHyperlink CRhinoUiHyperlink |
#define CRmaUiImageList CRhinoUiImageList |
#define CRmaUiInPlace CRhinoUiInPlace |
#define CRmaUiInPlaceButton CRhinoUiInPlaceButton |
#define CRmaUiInPlaceEdit CRhinoUiInPlaceEdit |
#define CRmaUiListBoxEx CRhinoUiListBoxEx |
#define CRmaUiListBoxExBuddy CRhinoUiListBoxExBuddy |
#define CRmaUiMemDC CRhinoUiMemDC |
#define CRmaUiPopUpListWnd CRhinoUiPopUpListWnd |
#define CRmaUiPopupMenu CRhinoUiPopupMenu |
#define CRmaUiPopuUpListBox CRhinoUiPopuUpListBox |
#define CRmaUiProgressBar CRhinoUiProgressBar |
#define CRmaUiRichEditCtrl CRhinoUiRichEditCtrl |
#define CRmaUiSeparator CRhinoUiSeparator |
#define CRmaUiStatic CRhinoUiStatic |
#define CRmaUiTextProgressCtrl CRhinoUiProgressCtrl |
#define CRmaUiThemeDraw CRhinoUiThemeDraw |
#define DIBColorDepth RhinoUiDIBColorDepth |
#define DIBCopy RhinoUiDIBCopy |
#define DIBCopyToClipboard RhinoUiDIBCopyToClipboard |
#define DIBCopyToHandle RhinoUiDIBCopyToHandle |
#define DIBCreate RhinoUiDIBCreate |
#define DIBCreateHBitmap RhinoUiDIBCreateHBitmap |
#define DIBFindBits RhinoUiDIBFindBits |
#define DIBGet256Palette RhinoUiDIBGet256Palette |
#define DIBHeight RhinoUiDIBHeight |
#define DIBLineSize RhinoUiDIBLineSize |
#define DIBNumColors RhinoUiDIBNumColors |
#define DIBPaletteSize RhinoUiDIBPaletteSize |
#define DIBScanWidth RhinoUiDIBScanWidth |
#define DIBSet256IdentityPalette RhinoUiDIBSet256IdentityPalette |
#define DIBSet256PalColors RhinoUiDIBSet256PalColors |
#define DIBSize RhinoUiDIBSize |
#define DIBSizeBits RhinoUiDIBSizeBits |
#define DIBWidth RhinoUiDIBWidth |
#define IDC_RHINOUI_GRIDLIST_COMBO (WM_USER * 2) |
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
#define RHINO_UI_COUNT_OF | ( | array | ) | ( sizeof(array) / sizeof( array[0])) |
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
#define RHINO_UILIB_DEFINE_GUID | ( | name, | |
l, | |||
w1, | |||
w2, | |||
b1, | |||
b2, | |||
b3, | |||
b4, | |||
b5, | |||
b6, | |||
b7, | |||
b8 | |||
) | EXTERN_C const GUID DECLSPEC_SELECTANY name; |
The above macro does not use legal C++. You cannot both declare and define a variable in a header file that is included everywhere. The following lines only declare the global variables and are duplicated in MacHelpers.mm to define the variables once.
#define RMADIB_CALLOC RHINOUI_DIB_CALLOC |
#define RMADIB_FREE RHINOUI_DIB_FREE |
#define RMADIB_MALLOC RHINOUI_DIB_MALLOC |
#define RmaDibInstallMemManager RhinoUiDibInstallMemManager |
typedef struct tagRhinoUiOptionsListCtrlNM * LPRhinoUiOptionsListCtrlNM |
typedef struct tagRhinoUiOptionsListCtrlNM RhinoUiOptionsListCtrlNM |
RHINO_SDK_FUNCTION CRhinoUiPaintManager::DrawExpanderHeaderOptions operator& | ( | CRhinoUiPaintManager::DrawExpanderHeaderOptions | a, |
CRhinoUiPaintManager::DrawExpanderHeaderOptions | b | ||
) |
RHINO_SDK_FUNCTION CRhinoUiPaintManager::DrawExpanderHeaderOptions& operator&= | ( | CRhinoUiPaintManager::DrawExpanderHeaderOptions & | a, |
CRhinoUiPaintManager::DrawExpanderHeaderOptions | b | ||
) |
RHINO_SDK_FUNCTION CRhinoUiPaintManager::DrawExpanderHeaderOptions operator| | ( | CRhinoUiPaintManager::DrawExpanderHeaderOptions | a, |
CRhinoUiPaintManager::DrawExpanderHeaderOptions | b | ||
) |
RHINO_SDK_FUNCTION CRhinoUiPaintManager::DrawExpanderHeaderOptions& operator|= | ( | CRhinoUiPaintManager::DrawExpanderHeaderOptions & | a, |
CRhinoUiPaintManager::DrawExpanderHeaderOptions | b | ||
) |
RHINO_SDK_FUNCTION CRhinoUiPaintManager::DrawExpanderHeaderOptions operator~ | ( | CRhinoUiPaintManager::DrawExpanderHeaderOptions | a | ) |
RHINO_SDK_FUNCTION COLORREF RhGetDialogBackgroundColor | ( | HWND | ctrl | ) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_CLASH_DOCK_BAR_ID | , |
0x770ff06a | , | ||
0xd775 | , | ||
0x41e4 | , | ||
0xbb | , | ||
0xc7 | , | ||
0x9f | , | ||
0x32 | , | ||
0xed | , | ||
0x18 | , | ||
0x9b | , | ||
0x5e | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_COMMAND_DOCK_BAR_ID | , |
0x1D3D1785 | , | ||
0x2332 | , | ||
0x428B | , | ||
0xA8 | , | ||
0x38 | , | ||
0xB2 | , | ||
0xFE | , | ||
0x39 | , | ||
0xEC | , | ||
0x50 | , | ||
0xF4 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_CONTOUR_ANALYSIS_DOCK_BAR_ID | , |
0xa0f238df | , | ||
0x1898 | , | ||
0x47cf | , | ||
0x91 | , | ||
0x9d | , | ||
0xf8 | , | ||
0x4d | , | ||
0xe9 | , | ||
0x5a | , | ||
0x0b | , | ||
0xb9 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_CURVATURE_ANALYSIS_DOCK_BAR_ID | , |
0x948D3151 | , | ||
0x91AA | , | ||
0x4959 | , | ||
0xAD | , | ||
0x67 | , | ||
0xBD | , | ||
0x49 | , | ||
0xFB | , | ||
0xB2 | , | ||
0x48 | , | ||
0x79 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_CURVATURE_GRAPH_DOCK_BAR_ID | , |
0x54D560F5 | , | ||
0xC1B2 | , | ||
0x4BBA | , | ||
0x95 | , | ||
0x34 | , | ||
0x3C | , | ||
0x00 | , | ||
0xE4 | , | ||
0x0D | , | ||
0x30 | , | ||
0x57 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_DIRECTION_ANALYSIS_DOCK_BAR_ID | , |
0x9a0a0262 | , | ||
0x6e97 | , | ||
0x4bb6 | , | ||
0xa9 | , | ||
0xc | , | ||
0x4f | , | ||
0xd7 | , | ||
0x93 | , | ||
0x1 | , | ||
0xd6 | , | ||
0x77 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_DOCKBARTAB_LAYER | , |
0x3610bf83 | , | ||
0x047d | , | ||
0x4f7f | , | ||
0x93 | , | ||
0xfd | , | ||
0x16 | , | ||
0x3e | , | ||
0xa3 | , | ||
0x05 | , | ||
0xb4 | , | ||
0x93 | |||
) |
Removed - these control bars are now included in the docking tab system. RHINO_UILIB_DEFINE_GUID( RHINO_LAYER_DOCK_BAR_ID, 0x16B641D3, 0x75AF, 0x4D2C, 0x86, 0x1E, 0xB9, 0x6E, 0x38, 0x7B, 0x6F, 0x80); RHINO_UILIB_DEFINE_GUID( RHINO_LAYER_MANAGER_DOCK_BAR_ID, 0x2363ed67, 0x616d, 0x4861, 0x9e, 0x87, 0xe2, 0xfe, 0x8f, 0xe7, 0x88, 0xa5); RHINO_UILIB_DEFINE_GUID( RHINO_PROPERTIES_DOCK_BAR_ID, 0x20A1348C, 0xD529, 0x44F6, 0x8B, 0xD3, 0xEC, 0x8C, 0x00, 0x1B, 0x2B, 0xB7); RHINO_UILIB_DEFINE_GUID( RHINO_NOTES_DOCK_BAR_ID, 0x6641B35A, 0xA21E, 0x4350, 0xA5, 0xF7, 0xCC, 0xCA, 0x3E, 0xC6, 0xAC, 0x72); RHINO_UILIB_DEFINE_GUID( RHINO_COMMAND_CONTEXT_BAR_ID, 0x7dd6a049, 0x72ca, 0x457d, 0xbf, 0x12, 0x37, 0x10, 0x0d, 0x7e, 0xe9, 0x67);
RHINO_UILIB_DEFINE_GUID | ( | RHINO_DOCKBARTAB_PROPERTIES | , |
0x34ffb674 | , | ||
0xc504 | , | ||
0x49d9 | , | ||
0x9f | , | ||
0xcd | , | ||
0x99 | , | ||
0xcc | , | ||
0x81 | , | ||
0x1d | , | ||
0xcd | , | ||
0xa2 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_DRAFT_ANGLE_DOCK_BAR_ID | , |
0xF814F8D8 | , | ||
0xEEC0 | , | ||
0x46FD | , | ||
0x85 | , | ||
0x85 | , | ||
0xE0 | , | ||
0xE8 | , | ||
0x48 | , | ||
0x6A | , | ||
0xB8 | , | ||
0x4D | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_DRAFT_ANGLE_ETO_DOCK_BAR_ID | , |
0xFE0CBB9E | , | ||
0x336B | , | ||
0x4482 | , | ||
0x9A | , | ||
0xBE | , | ||
0xB9 | , | ||
0x4B | , | ||
0x35 | , | ||
0xB0 | , | ||
0x08 | , | ||
0xFD | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_DRAG_STRENGTH_DOCK_BAR_ID | , |
0x50eb6c7b | , | ||
0xbe0 | , | ||
0x4166 | , | ||
0xad | , | ||
0x17 | , | ||
0xea | , | ||
0x69 | , | ||
0x4c | , | ||
0x97 | , | ||
0xa6 | , | ||
0xf4 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_EDGE_ANALYSIS_DOCK_BAR_ID | , |
0xC9FB93D6 | , | ||
0xC1AB | , | ||
0x4464 | , | ||
0xAD | , | ||
0x3A | , | ||
0xED | , | ||
0x2A | , | ||
0x8B | , | ||
0xC1 | , | ||
0x20 | , | ||
0x9B | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_EDGE_CONTINUITY_DOCK_BAR_ID | , |
0xf7cda9c5 | , | ||
0xa66c | , | ||
0x4ae6 | , | ||
0x87 | , | ||
0xb5 | , | ||
0x89 | , | ||
0xc2 | , | ||
0x42 | , | ||
0x54 | , | ||
0xe3 | , | ||
0xb3 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_EMAP_DOCK_BAR_ID | , |
0xCA1753B1 | , | ||
0xAE23 | , | ||
0x4880 | , | ||
0xAD | , | ||
0x93 | , | ||
0x39 | , | ||
0xB5 | , | ||
0x29 | , | ||
0x95 | , | ||
0x22 | , | ||
0xE6 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_END_ANALYSIS_DOCK_BAR_ID | , |
0x4c2d9eed | , | ||
0xbc64 | , | ||
0x48ba | , | ||
0xb9 | , | ||
0x10 | , | ||
0x40 | , | ||
0xa0 | , | ||
0xe6 | , | ||
0x5c | , | ||
0xa | , | ||
0xe3 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_OSNAP_DOCK_BAR_ID | , |
0xd3c4a392 | , | ||
0x88de | , | ||
0x4c4f | , | ||
0x88 | , | ||
0xa4 | , | ||
0xba | , | ||
0x56 | , | ||
0x36 | , | ||
0xef | , | ||
0x7f | , | ||
0x38 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_SELECTION_FILTER_DOCK_BAR_ID | , |
0x918191ca | , | ||
0x1105 | , | ||
0x43f9 | , | ||
0xa3 | , | ||
0x4a | , | ||
0xdd | , | ||
0xa4 | , | ||
0x27 | , | ||
0x68 | , | ||
0x83 | , | ||
0xc1 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_THICKNESS_DISP_DOCK_BAR_ID | , |
0xc0c9e0f1 | , | ||
0xd554 | , | ||
0x453b | , | ||
0x87 | , | ||
0x12 | , | ||
0xa0 | , | ||
0x20 | , | ||
0xac | , | ||
0xe0 | , | ||
0xb8 | , | ||
0xe4 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_UI_FILE_CLOSED_EVENT | , |
0x2395e5fc | , | ||
0xdf89 | , | ||
0x49bd | , | ||
0xa6 | , | ||
0xee | , | ||
0x2e | , | ||
0xe0 | , | ||
0x0 | , | ||
0x10 | , | ||
0x24 | , | ||
0xb5 | |||
) |
Description: CRhinoUiFileEvent File closed event {2395E5FC-DF89-49BD-A6EE-2EE0001024B5}
RHINO_UILIB_DEFINE_GUID | ( | RHINO_UI_FILE_MACRO_DELETE_EVENT | , |
0x221ecf6b | , | ||
0xe12 | , | ||
0x4a3b | , | ||
0xae | , | ||
0x4b | , | ||
0x91 | , | ||
0xe4 | , | ||
0xde | , | ||
0x75 | , | ||
0xa | , | ||
0x5f | |||
) |
Description: CRhinoUiFileEvent macro deleted event {221ECF6B-0E12-4A3B-AE4B-91E4DE750A5F}
RHINO_UILIB_DEFINE_GUID | ( | RHINO_UI_FILE_MACRO_MODIFIED_EVENT | , |
0x7f30da3f | , | ||
0x54cb | , | ||
0x4964 | , | ||
0xbf | , | ||
0xff | , | ||
0xf | , | ||
0x28 | , | ||
0x79 | , | ||
0x87 | , | ||
0x6f | , | ||
0x85 | |||
) |
Description: CRhinoUiFileEvent existing macro modified event {7F30DA3F-54CB-4964-BFFF-0F2879876F85}
RHINO_UILIB_DEFINE_GUID | ( | RHINO_UI_FILE_MACRO_NEW_EVENT | , |
0x498d441f | , | ||
0x66 | , | ||
0x48ab | , | ||
0x87 | , | ||
0xd | , | ||
0x7c | , | ||
0xcc | , | ||
0x4b | , | ||
0x34 | , | ||
0x10 | , | ||
0xa3 | |||
) |
Description: CRhinoUiFileEvent new macro added event {498D441F-0066-48AB-870D-7CCC4B3410A3}
RHINO_UILIB_DEFINE_GUID | ( | RHINO_UI_FILE_OPEN_EVENT | , |
0x5fa9bc7f | , | ||
0xd8ef | , | ||
0x40fd | , | ||
0x91 | , | ||
0xf4 | , | ||
0x57 | , | ||
0xcf | , | ||
0xf2 | , | ||
0x22 | , | ||
0xcd | , | ||
0xe2 | |||
) |
CRhinoUiFileEvent Event Id's.
Description: CRhinoUiFileEvent File opened event {5FA9BC7F-D8EF-40FD-91F4-57CFF222CDE2}
RHINO_UILIB_DEFINE_GUID | ( | RHINO_VIEW_MANAGER_DOCK_BAR_ID | , |
0x844b3278 | , | ||
0xe78e | , | ||
0x4844 | , | ||
0x86 | , | ||
0x8d | , | ||
0x63 | , | ||
0x9b | , | ||
0x9b | , | ||
0x65 | , | ||
0x46 | , | ||
0x50 | |||
) |
RHINO_UILIB_DEFINE_GUID | ( | RHINO_ZEBRA_DOCK_BAR_ID | , |
0x36EF80FE | , | ||
0x7D51 | , | ||
0x41EE | , | ||
0x80 | , | ||
0x44 | , | ||
0xF1 | , | ||
0x7B | , | ||
0x10 | , | ||
0x73 | , | ||
0x09 | , | ||
0xCB | |||
) |
RHINO_SDK_FUNCTION ON_FileReference RhinoGetDibAsTextureFileReference | ( | const CRhinoDib & | dib, |
ON__UINT32 | crc | ||
) |
Description: Inserts dib into Rhino's texture manager and returns an ON_FileReference for use in e.g. ON_Texture::m_image_file_reference. This way it's possible to use a dib with an ON_Texture without having to read the dib from file. Parameters: dib - [in] The dib which will be referenced by the ON_FileReference. crc - [in] The crc of the dib. This should be a unique number which changes if the contents of the dib changes. NOTE: if a different dib is provided using the same crc as a previous dib, then the previous dib will be overwritten in the texture manager and both previously returned ON_FileReferences will reference the newly provided dib. Returns: Returns an ON_FileReference which, when used together with e.g. ON_Texture::m_image_file_reference, is used by Rhino's display to find the texture from the texture manager.
RHINO_SDK_FUNCTION bool RhinoOnToolBarButtonClicked | ( | const wchar_t * | lpsMacro, |
const wchar_t * | lpsTooltip | ||
) |
RHINO_SDK_FUNCTION int RhinoRoundOff | ( | double | x | ) |
void* RHINOUI_DIB_CALLOC | ( | size_t | num, |
size_t | size | ||
) |
void RHINOUI_DIB_FREE | ( | void * | memblock | ) |
void* RHINOUI_DIB_MALLOC | ( | size_t | size | ) |
RHINO_SDK_FUNCTION void RhinoUiAddTabFactory | ( | CRhinoUiPanelFactory * | pFactory | ) |
RHINO_SDK_FUNCTION void RhinoUiCloseDockbarTab | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId, | ||
const ON_UUID * | uuidDockBar = nullptr |
||
) |
Description: Hides the panel. Does not destroy it. If the panel is on a dockbar with a single tab, the dockbar will instead be hidden. Parameters: pDoc [in] The document that this panel displays information for. uuidTabId [in] Panel to close.
void RHINO_SDK_FUNCTION RhinoUiColorComboBoxItemDataInit | ( | RhinoUiColorComboBoxItemData & | data | ) |
RHINO_SDK_FUNCTION bool RhinoUiColorDialog | ( | CWnd * | pWndParent, |
ON_Color & | color, | ||
bool | include_button_colors = false , |
||
const wchar_t * | dialog_title = NULL |
||
) |
RHINO_SDK_FUNCTION void RhinoUiCreateTabQuietly | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId | ||
) |
Description: Constructs a panel. It is not attached to any dockbar. This is generally used where the code inside the dockbar is required (Properties - I'm looking at you), but it doesn't need to be shown. Parameters: pDoc [in] The document that this panel should display information for. uuidTabId [in] Panel to create. If this is nullptr, the framework will determine the host itself, depending on the platform and previously saved state.
void RhinoUiDibInstallMemManager | ( | void *(*)(size_t num, size_t size) | my_calloc, |
void *(*)(size_t size) | my_malloc, | ||
void(*)(void *memblock) | my_free | ||
) |
Copyright (c) 1993-2022 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer.
RHINO_SDK_FUNCTION CRhinoUiDockBar* RhinoUiDockBarForTab | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId | ||
) |
RHINO_SDK_FUNCTION CRhinoUiDockBarManager& RhinoUiDockBarManager | ( | ) |
RHINO_SDK_FUNCTION void RhinoUiDockBarsForTab | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId, | ||
ON_SimpleArray< CRhinoUiDockBar * > & | dockbars | ||
) |
RHINO_SDK_FUNCTION void RhinoUiDockBarsForTab | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId, | ||
ON_SimpleArray< ON_UUID > & | dockbars | ||
) |
RHINO_SDK_FUNCTION void RhinoUiDockBarsForTab | ( | const ON_UUID & | uuidTabId, |
ON_SimpleArray< CRhinoUiDockBar * > & | dockbars | ||
) |
Use this function only when uuidTabId refers to a panel without document context.
RHINO_SDK_FUNCTION CRhinoUiDockBarTab* RhinoUiDockBarTabFromId | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId | ||
) |
Description: Get a tab from a tab class Id. Parameters: pDoc [in] Document this panel displays. uuidTabId [in] Tab to search for Returns: Returns the tab specified by uuidTabId or nullptr if the tab has not been created yet.
RHINO_SDK_FUNCTION void RhinoUiDockBarTabsFromId | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId, | ||
ON_SimpleArray< CRhinoUiDockBarTab * > & | dockbartabs | ||
) |
RHINO_SDK_FUNCTION void RhinoUiDockBarTabUpdateIcon | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId | ||
) |
Description: Update the icon for a specific tab. If the tab is visible then the CRhinoUiDockBarTab::Icon method will get called for each tab in the container which includes the specified tab. If the tab is not found or is visible then nothing happens. Parameters: doc [in] Document to update the panel(s) for. uuidTabId [in] Tab to update
RHINO_SDK_FUNCTION void RhinoUiEnableTabFactory | ( | const ON_UUID & | uuidTabId, |
bool | b | ||
) |
void RHINO_SDK_FUNCTION RhinoUiFontComboBoxItemDataInit | ( | RhinoUiFontComboBoxItemData & | data | ) |
RHINO_SDK_FUNCTION bool RhinoUiIsDisabledTabbedDockBar | ( | CControlBar * | ) |
RHINO_SDK_FUNCTION bool RhinoUiIsTabFactoryEnabled | ( | const ON_UUID & | uuidTabId | ) |
RHINO_SDK_FUNCTION bool RhinoUiIsTabVisible | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId, | ||
bool | bIsSelectedTab = true |
||
) |
Description: Determines if the panel is visible for a specific document. Parameters: pDoc [in] The document that this panel displays information for. uuidTabId [in] Panel to check. bIsSelectedTab [in] Only return true if the panel is actually on the selected tab of a tabbed dockbar.
void RHINO_SDK_FUNCTION RhinoUiLayerComboBoxItemDataInit | ( | RhinoUiLayerComboBoxItemData & | data | ) |
UINT RhinoUiLayerListCtrlColumnClickMessageId | ( | ) |
void RHINO_SDK_FUNCTION RhinoUiLinetypeComboBoxItemDataInit | ( | RhinoUiLinetypeComboBoxItemData & | data | ) |
RHINO_SDK_FUNCTION CFrameWnd* RhinoUiMainFrame | ( | ) |
RHINO_SDK_FUNCTION HWND RhinoUiMainFrameHWND | ( | ) |
RHINO_SDK_FUNCTION CRhinoUiManager& RhinoUiManager | ( | ) |
RHINO_SDK_FUNCTION CRhinoUiModlessDockingDialogManager& RhinoUiModlessDockingDialogManager | ( | ) |
RHINO_SDK_FUNCTION AFX_MODULE_STATE* RhinoUiModuleState | ( | ) |
RHINO_SDK_FUNCTION CRhinoUiDockBar* RhinoUiOpenDockbarTab | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId, | ||
bool | makeSelectedTab = true , |
||
const ON_UUID * | uuidDockBar = nullptr |
||
) |
Description: Creates a panel complete with a tab. If no dockbar uuid is given, the framework will decide where to put it. Parameters: pDoc [in] The document that this panel should display information for. uuidTabId [in] Panel to create. makeSelectedTab[in] Switch to this tab in the tab control that hosts this panel. uuidDockBar [in, optional] Specifies the host container id. If this is nullptr, the framework will determine the host itself, depending on the platform and previously saved state.
RHINO_SDK_FUNCTION CRhinoUiDockBar* RhinoUiOpenDockbarTab | ( | const ON_UUID & | uuidTabId, |
bool | makeSelectedTab = true , |
||
const ON_UUID * | uuidDockBar = nullptr |
||
) |
Description: Creates a document context panel, or a document panel placeholder complete with a tab. If no dockbar uuid is given, the framework will decide where to put it. Parameters: uuidTabId [in] Panel to create. makeSelectedTab[in] Switch to this tab in the tab control that hosts this panel. uuidDockBar [in, optional] Specifies the host container id. If this is nullptr, the framework will determine the host itself, depending on the platform and previously saved state.
RHINO_SDK_FUNCTION CRhinoUiPageDockBarManager& RhinoUiPageDockBarManager | ( | ) |
RHINO_SDK_FUNCTION CRhinoUiPaintManager& RhinoUiPaintManager | ( | ) |
RHINO_SDK_FUNCTION void RhinoUiPanelFactories | ( | ON_SimpleArray< const CRhinoUiPanelFactory * > & | factories | ) |
const RHINO_SDK_FUNCTION CRhinoUiPanelFactory* RhinoUiPanelFactoryFromId | ( | const ON_UUID & | id | ) |
void RHINO_SDK_FUNCTION RhinoUiPrintWidthComboBoxItemDataInit | ( | RhinoUiPrintWidthComboBoxItemData & | data | ) |
RHINO_SDK_FUNCTION void RhinoUiRegisteredDockbarTabs | ( | ON_SimpleArray< ON_UUID > & | aTabIds | ) |
RHINO_SDK_FUNCTION CRhinoUiResourceManager& RhinoUiResourceManager | ( | ) |
RHINO_SDK_FUNCTION bool RhinoUiScaleLocalizedFonts | ( | ) |
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
RHINO_SDK_FUNCTION bool RhinoUiScaleLocalizedFonts | ( | UINT & | nSize | ) |
RHINO_SDK_FUNCTION void RhinoUiShowDockbarTab | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId, | ||
bool | bShow, | ||
bool | bMakeSelected, | ||
const ON_UUID * | uuidDockBar = nullptr |
||
) |
Description: This function is essentially a wrapper around RhinoUiOpenDockbarTab/RhinoUiCloseDockbarTab, depending on the bShow value. Parameters: pDoc [in] The document that this panel displays information for. uuidTabId [in] Panel to close. bShow [in] true for show, false for hide. bMakeSelected [in] true to select the tab that the panel is on, false otherwise. Ignored when bShow is false.
RHINO_SDK_FUNCTION void RhinoUiShowDockbarTab | ( | const CRhinoDoc & | doc, |
const ON_UUID & | uuidTabId, | ||
bool | bShow, | ||
const ON_UUID * | uuidDockBar = nullptr |
||
) |
RHINO_SDK_FUNCTION void RhinoUiTabHostIds | ( | const CRhinoDoc & | doc, |
const ON_UUID & | panelId, | ||
ON_SimpleArray< ON_UUID > & | hostIds | ||
) |
Description: Gets a list of host container Id's that include the specified panel. Parameters: doc [in] Will only look for host containers associated with this docuument, on Mac there may be several per document. panelId [in] Will check the container to see if it includes a panel with this Id. hostIds [out] Will contain the Id of each appropriate container.
RHINO_SDK_DATA UUID uuidPanelContextHelp |
RHINO_SDK_DATA UUID uuidPanelDisplay |
RHINO_SDK_DATA UUID uuidPanelEnvironments |
RHINO_SDK_DATA UUID uuidPanelFileExplorer |
RHINO_SDK_DATA UUID uuidPanelGroundPlane |
RHINO_SDK_DATA UUID uuidPanelLayers |
RHINO_SDK_DATA UUID uuidPanelLibraries |
RHINO_SDK_DATA UUID uuidPanelLightManager |
RDK panels.
RHINO_SDK_DATA UUID uuidPanelMaterials |
RHINO_SDK_DATA UUID uuidPanelNotes |
RHINO_SDK_DATA UUID uuidPanelObjectProps |
RHINO_SDK_DATA UUID uuidPanelRenderSettings |
RHINO_SDK_DATA UUID uuidPanelSun |
RHINO_SDK_DATA UUID uuidPanelTextures |