Rhino C++ API
8.13
|
#include <RhinoSdkUiTabCtrl.h>
Public Member Functions | |
CRhinoUiTabCtrl () | |
virtual | ~CRhinoUiTabCtrl () |
virtual void | DrawItem (LPDRAWITEMSTRUCT) |
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct) |
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor) |
afx_msg void | OnNcPaint () |
Protected Member Functions | |
virtual void | PreSubclassWindow () |
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
CRhinoUiTabCtrl::CRhinoUiTabCtrl | ( | ) |
|
virtual |
|
virtual |
afx_msg int CRhinoUiTabCtrl::OnCreate | ( | LPCREATESTRUCT | lpCreateStruct | ) |
afx_msg HBRUSH CRhinoUiTabCtrl::OnCtlColor | ( | CDC * | pDC, |
CWnd * | pWnd, | ||
UINT | nCtlColor | ||
) |
afx_msg void CRhinoUiTabCtrl::OnNcPaint | ( | ) |
|
protectedvirtual |
Reimplemented in CRhinoUiTabPageCtrl.