Rhino C++ API  8.6
Public Member Functions | List of all members
IRhRdkContentFactoriesEx Class Referenceabstract

#include <IRhRdkContentFactories.h>

Inheritance diagram for IRhRdkContentFactoriesEx:
IRhRdkContentFactories

Public Member Functions

virtual CRhRdkContentNewContentFromTypeEx (const UUID &uuidType, const CRhinoDoc *pDocAssoc) const =0
 
- Public Member Functions inherited from IRhRdkContentFactories
virtual ~IRhRdkContentFactories ()
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual CRhRdkContentFactoryFindFactory (const UUID &uuidType) const =0
 
virtual CRhRdkContentFactoryFirstFactory (void) const =0
 
virtual CRhRdkContentNewContentFromType (const UUID &uuidType) const =0
 
virtual CRhRdkContentFactoryNextFactory (void) const =0
 

Member Function Documentation

◆ NewContentFromTypeEx()

virtual CRhRdkContent* IRhRdkContentFactoriesEx::NewContentFromTypeEx ( const UUID &  uuidType,
const CRhinoDoc pDocAssoc 
) const
pure virtual

Create a new content from the specified content type.

Note
This method calls Initialize() on the new content. If this fails, the new content is deleted and this method returns nullptr. Use this function in preference to NewContentFromType(const UUID& uuidType)
Returns
A pointer to a new instance of the content that this factory produces.