Rhino C++ API  8.6
Public Member Functions | List of all members
IRhRdkContentFactories Class Referenceabstract

#include <IRhRdkContentFactories.h>

Inheritance diagram for IRhRdkContentFactories:
IRhRdkContentFactoriesEx

Public Member Functions

virtual ~IRhRdkContentFactories ()
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual CRhRdkContentFactoryFindFactory (const UUID &uuidType) const =0
 
virtual CRhRdkContentFactoryFirstFactory (void) const =0
 
virtual CRhRdkContentNewContentFromType (const UUID &uuidType) const =0
 
virtual CRhRdkContentFactoryNextFactory (void) const =0
 

Detailed Description

This interface represents the collection of all content factories that are registered with the RDK.

Content factories are RDK extensions. You usually add new content factories to the system when you are called on your implementation of CRhRdkPlugIn::RegisterExtensions(). If necessary, you can also add new factories later by calling RhRdkAddExtension(). Factories so added can be found again later by calling RhRdkContentFactories() which returns this interface.

See also
CRhRdkPlugIn::RegisterExtensions()

Constructor & Destructor Documentation

◆ ~IRhRdkContentFactories()

virtual IRhRdkContentFactories::~IRhRdkContentFactories ( )
inlinevirtual

Member Function Documentation

◆ EVF()

virtual void* IRhRdkContentFactories::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ FindFactory()

virtual CRhRdkContentFactory* IRhRdkContentFactories::FindFactory ( const UUID &  uuidType) const
pure virtual

Find the factory that creates content of the specified type.

Returns
A pointer to the factory or nullptr if not found.

◆ FirstFactory()

virtual CRhRdkContentFactory* IRhRdkContentFactories::FirstFactory ( void  ) const
pure virtual

Get a pointer to the first factory in the collection.

Returns
A pointer to the first factory or nullptr if there are none.

◆ NewContentFromType()

virtual CRhRdkContent* IRhRdkContentFactories::NewContentFromType ( const UUID &  uuidType) const
pure virtual

Create a new content from the specified content type.

Note
This method calls Initialize() on the new content. If this fails, the new content is deleted and this method returns nullptr.
Returns
A pointer to a new instance of the content that this factory produces.

◆ NextFactory()

virtual CRhRdkContentFactory* IRhRdkContentFactories::NextFactory ( void  ) const
pure virtual

Get a pointer to the next factory in the collection.

Returns
A pointer to the next factory or nullptr if no more.