Rhino C++ API
8.17
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
IRhRdkContentList
Iterator
Public Member Functions
|
List of all members
IRhRdkContentList::Iterator Class Reference
abstract
#include <IRhRdkContentList.h>
Public Member Functions
virtual
~Iterator
()
virtual const
CRhRdkContent
*
Next
(void)=0
Constructor & Destructor Documentation
◆
~Iterator()
virtual IRhRdkContentList::Iterator::~Iterator
(
)
inline
virtual
Member Function Documentation
◆
Next()
virtual const
CRhRdkContent
* IRhRdkContentList::Iterator::Next
(
void
)
pure virtual
Returns
A pointer to the next content in the list or NULL if no more exist.
Generated on Wed Mar 12 2025 13:56:14 for Rhino C++ API by
1.8.17