Rhino C++ API
8.13
|
#include <IRhRdkContentList.h>
Classes | |
class | Iterator |
Public Member Functions | |
virtual | ~IRhRdkContentList () |
virtual int | Count (void) const =0 |
virtual void * | EVF (const wchar_t *, void *)=0 |
virtual const CRhRdkContent * | FindInstance (const UUID &uuidInstance, bool bRecurse) const =0 |
virtual void | FindInstanceByName (const wchar_t *wszName, bool bCaseSensitive, bool bRecurse, OUT CRhRdkContentArray &aContent) const =0 |
virtual void | GetKinds (CRhRdkContentKindList &kindsOut) const =0 |
virtual Iterator * | NewIterator (void) const =0 |
virtual const CRhRdkContent * | Next (Iterator *pIterator) const =0 |
virtual UUID | Uuid (void) const =0 |
This interface is used for accessing lists of content. Any kind of content can coexist in such a list, although some actual lists in RDK allow only a single kind.
|
inlinevirtual |
|
pure virtual |
|
pure virtual |
Emergency virtual function for future expansion.
|
pure virtual |
Find a content by its instance id.
uuidInstance | is the instance id of the content to find. |
bRecurse | specifies if children should be searched as well as top-level content. |
|
pure virtual |
Find contents with the specified instance name.
wszName | is the name to search for. |
bCaseSensitive | specifies if the name check is case-sensitive or not. |
bRecurse | specifies if the content's children should be searched. |
aContent | accepts all the contents that satisfy the search. |
|
pure virtual |
Get the content kinds that the list contains.
|
pure virtual |
Get an iterator to use when calling Next(). The caller shall delete the iterator.
|
pure virtual |
|
pure virtual |