Rhino C++ API  8.6
Public Member Functions | List of all members
IRhRdkParamBlock::IParam Class Referenceabstract

#include <RhRdkAutomaticUI.h>

Public Member Functions

virtual ~IParam ()
 
virtual const wchar_t * ChildSlotName (void) const =0
 
virtual const wchar_t * DisplayName (void) const =0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual class IAutoUIExtraRequirementsExtraReqPtr (void) const =0
 
virtual const wchar_t * ExtraReqs (void) const =0
 
virtual bool IsEnabled (void) const =0
 
virtual bool IsGreaterThan (SortBy by, const IParam &p) const =0
 
bool IsHidden (void) const
 
virtual bool IsLessThan (SortBy by, const IParam &p) const =0
 
virtual const CRhRdkVariantMax (void) const =0
 
virtual const CRhRdkVariantMin (void) const =0
 
virtual const wchar_t * ParamName (void) const =0
 
virtual void SetIsEnabled (bool bEnabled)=0
 
void SetIsHidden (bool bHidden)
 
virtual void SetValue (const CRhRdkVariant &v)=0
 
virtual UiHints UiHint (void) const =0
 
virtual CRhRdkVariant Value (void) const =0
 

Constructor & Destructor Documentation

◆ ~IParam()

virtual IRhRdkParamBlock::IParam::~IParam ( )
inlinevirtual

Member Function Documentation

◆ ChildSlotName()

virtual const wchar_t* IRhRdkParamBlock::IParam::ChildSlotName ( void  ) const
pure virtual

◆ DisplayName()

virtual const wchar_t* IRhRdkParamBlock::IParam::DisplayName ( void  ) const
pure virtual

◆ EVF()

virtual void* IRhRdkParamBlock::IParam::EVF ( const wchar_t *  ,
void *   
)
pure virtual

◆ ExtraReqPtr()

virtual class IAutoUIExtraRequirements* IRhRdkParamBlock::IParam::ExtraReqPtr ( void  ) const
pure virtual

◆ ExtraReqs()

virtual const wchar_t* IRhRdkParamBlock::IParam::ExtraReqs ( void  ) const
pure virtual

◆ IsEnabled()

virtual bool IRhRdkParamBlock::IParam::IsEnabled ( void  ) const
pure virtual

◆ IsGreaterThan()

virtual bool IRhRdkParamBlock::IParam::IsGreaterThan ( SortBy  by,
const IParam p 
) const
pure virtual

◆ IsHidden()

bool IRhRdkParamBlock::IParam::IsHidden ( void  ) const

◆ IsLessThan()

virtual bool IRhRdkParamBlock::IParam::IsLessThan ( SortBy  by,
const IParam p 
) const
pure virtual

◆ Max()

virtual const CRhRdkVariant& IRhRdkParamBlock::IParam::Max ( void  ) const
pure virtual

◆ Min()

virtual const CRhRdkVariant& IRhRdkParamBlock::IParam::Min ( void  ) const
pure virtual

◆ ParamName()

virtual const wchar_t* IRhRdkParamBlock::IParam::ParamName ( void  ) const
pure virtual

◆ SetIsEnabled()

virtual void IRhRdkParamBlock::IParam::SetIsEnabled ( bool  bEnabled)
pure virtual

◆ SetIsHidden()

void IRhRdkParamBlock::IParam::SetIsHidden ( bool  bHidden)

◆ SetValue()

virtual void IRhRdkParamBlock::IParam::SetValue ( const CRhRdkVariant v)
pure virtual

◆ UiHint()

virtual UiHints IRhRdkParamBlock::IParam::UiHint ( void  ) const
pure virtual

◆ Value()

virtual CRhRdkVariant IRhRdkParamBlock::IParam::Value ( void  ) const
pure virtual