Rhino C++ API
8.13
|
#include <IAutoUIExtraRequirements.h>
Public Types | |
enum | SetContext : unsigned int { SetContext::UI, SetContext::Drop, SetContext::Program } |
Public Member Functions | |
virtual | ~IAutoUIExtraRequirements () |
virtual IAutoUIExtraRequirements * | DuplicateExtraRequirementsInterface (void) const =0 |
virtual void * | EVF (const wchar_t *, void *)=0 |
virtual bool | GetExtraRequirementParameter (const wchar_t *wszParamName, const wchar_t *wszExtraReqName, CRhRdkVariant &vValueOut) const =0 |
virtual bool | OnExtraRequirementButtonClicked (const wchar_t *wszParamName, const wchar_t *wszButtonName)=0 |
virtual bool | SetExtraRequirementParameter (const wchar_t *wszParamName, const wchar_t *wszExtraReqName, const CRhRdkVariant &vValue, SetContext sc)=0 |
Extra requirements are a way of specifying extra functionality on parameters in the automatic UI. All objects that support such extra UI requirements must implement this interface.
RDK currently supports the following extra requirements:
|
strong |
|
inlinevirtual |
|
pure virtual |
Implemented in CRhRdkContent.
|
pure virtual |
Emergency virtual function for future expansion.
Implemented in CRhRdkTexture, CRhRdkMaterial, CRhRdkCoreContent, CRhRdkEnvironment, and CRhRdkContent.
|
pure virtual |
Implement this method to get a parameter for extra UI requirements.
wszParamName | is the name of the content parameter for which to get an extra req. parameter. |
wszExtraReqName | is the name of the extra requirement parameter to retrieve. |
vValueOut | receives the parameter's value. |
Implemented in CRhRdkBasicMaterial, CRhRdkTwoColorTextureBase, CRhRdkOneColorTextureBase, and CRhRdkContent.
|
pure virtual |
Implement this method to handle an extra UI requirements button click.
wszParamName | is the name of the content parameter for which a button was clicked. |
wszButtonName | is the name of the button that was clicked. |
Implemented in CRhRdkContent.
|
pure virtual |
Implement this method to set a parameter for extra UI requirements.
wszParamName | is the name of the content parameter for which to set an extra req. parameter. |
wszExtraReqName | is the name of the extra requirement parameter to be set. |
vValue | contains the new value for the specified extra req. parameter. |
sc | is the context in which the set operation is being performed. |
Implemented in CRhRdkBasicMaterial, CRhRdkTwoColorTextureBase, CRhRdkOneColorTextureBase, and CRhRdkContent.