Rhino C++ API  8.6
Public Member Functions | List of all members
IRhRdkPreviewSceneServer::IGeometry Class Referenceabstract

#include <IRhRdkPreviewSceneServer.h>

Public Member Functions

virtual void ApplyUVMapping (ON_Mesh &meshOut) const =0
 
virtual void CreateLocalMesh (ON_Mesh &meshOut) const =0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual double Height (void) const =0
 
virtual double Radius (void) const =0
 
virtual eGeometry Type (void) const =0
 
virtual double Width (void) const =0
 

Member Function Documentation

◆ ApplyUVMapping()

virtual void IRhRdkPreviewSceneServer::IGeometry::ApplyUVMapping ( ON_Mesh meshOut) const
pure virtual

Apply UV mapping to the geometry.

◆ CreateLocalMesh()

virtual void IRhRdkPreviewSceneServer::IGeometry::CreateLocalMesh ( ON_Mesh meshOut) const
pure virtual

Create a mesh of the geometry centered at the origin.

◆ EVF()

virtual void* IRhRdkPreviewSceneServer::IGeometry::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ Height()

virtual double IRhRdkPreviewSceneServer::IGeometry::Height ( void  ) const
pure virtual
Returns
Height of cuboid, cone, cylinder or pyramid.

◆ Radius()

virtual double IRhRdkPreviewSceneServer::IGeometry::Radius ( void  ) const
pure virtual
Returns
Radius of sphere, radius of base of cone or cylinder.

◆ Type()

virtual eGeometry IRhRdkPreviewSceneServer::IGeometry::Type ( void  ) const
pure virtual

◆ Width()

virtual double IRhRdkPreviewSceneServer::IGeometry::Width ( void  ) const
pure virtual
Returns
Width of cuboid or base of pyramid.