Rhino C++ API
8.13
|
#include <IRhRdkPreviewSceneServer.h>
Classes | |
class | ICancellation |
class | IGeometry |
class | IObject |
Public Types | |
enum | eGeometry { geomSphere = 0, geomCuboid = 1, geomCone = 2, geomPyramid = 3, geomTorus = 4, geomPlane = 5, geomSelectedObjects = 6, geomMesh = 7, geomForce32bit = 0xFFFFFFFF } |
enum | eRotationType { camera, object, unset } |
Public Member Functions | |
virtual | ~IRhRdkPreviewSceneServer () |
virtual void | ApplyRotation (double dRotationX, double dRotationY, eRotationType type)=0 |
virtual ICancellation * | CancellationToken () const =0 |
virtual CRhRdkContent::Kinds | ContentKind (void) const =0 |
virtual const UUID & | ContentPluginId (void) const =0 |
virtual const UUID & | ContentType (void) const =0 |
virtual const CRhRdkEnvironment * | Environment (void) const =0 |
virtual void * | EVF (const wchar_t *, void *)=0 |
virtual bool | GetView (ON_Viewport &view) const =0 |
virtual int | LightCount (void) const =0 |
virtual const IRhRdkLinearWorkflow & | LinearWorkflow (void) const =0 |
RDK_DEPRECATED const class CRhRdkLinearWorkflow & | LinearWorkfow (void) const |
virtual const ON_Light * | NextLight (void) const =0 |
virtual const IObject * | NextObject (void) const =0 |
virtual int | ObjectCount (void) const =0 |
virtual void | ResetLightEnumerator (void) const =0 |
virtual void | ResetObjectEnumerator (void) const =0 |
virtual void | SetCacheImage (const CRhinoDib &image, const UUID &uuidRenderEngine) const =0 |
virtual void | SetCancellationToken (ICancellation *)=0 |
virtual void | SetSceneScale (double dScale)=0 |
virtual DWORD | Signature (void) const =0 |
virtual bool | Skylighting (void) const =0 |
This is the interface to RDK's scene server which provides the information necessary to render a preview of a material or an environment.
|
inlinevirtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
Return the kind of the content being previewed.
|
pure virtual |
Return the plug-in id of the content being previewed.
|
pure virtual |
Return the type id of the content being previewed.
|
pure virtual |
|
pure virtual |
Emergency virtual function for future expansion.
|
pure virtual |
Get information about the view.
|
pure virtual |
|
pure virtual |
Support for linear workflow in the preview scene.
RDK_DEPRECATED const class CRhRdkLinearWorkflow& IRhRdkPreviewSceneServer::LinearWorkfow | ( | void | ) | const |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |
Reset the enumerator used by NextObject().
|
pure virtual |
Set the image used to cache the thumbnail for this scene.
|
pure virtual |
|
pure virtual |
Set the scale of the scene.
|
pure virtual |
|
pure virtual |