Rhino C++ API  8.6
Public Member Functions | List of all members
ON_2dPointArray Class Reference

#include <opennurbs_point.h>

Inheritance diagram for ON_2dPointArray:
ON_SimpleArray< ON_2dPoint >

Public Member Functions

 ON_2dPointArray ()
 see ON_SimpleArray class definition comments for constructor documentation More...
 
 ON_2dPointArray (const ON_2dPointArray &)
 
 ON_2dPointArray (int)
 
bool GetBBox (double boxmin[2], double boxmax[2], bool bGrowBox=false) const
 
ON_2dPointArrayoperator= (const ON_2dPointArray &)
 
bool SwapCoordinates (int, int)
 
bool Transform (const ON_Xform &)
 
- Public Member Functions inherited from ON_SimpleArray< ON_2dPoint >
 ON_SimpleArray () ON_NOEXCEPT
 construction //////////////////////////////////////////////////////// More...
 
 ON_SimpleArray (const ON_SimpleArray< ON_2dPoint > &)
 Copy constructor. More...
 
 ON_SimpleArray (size_t)
 size_t parameter = initial capacity More...
 
virtual ~ON_SimpleArray ()
 
void Append (const ON_2dPoint &)
 
void Append (int, const ON_2dPoint *)
 Append copy of an array T[count]. More...
 
ON_2dPointAppendNew ()
 array operations //////////////////////////////////////////////////// More...
 
ON_2dPointArray ()
 The Array() function return the. More...
 
const ON_2dPointArray () const
 m_a pointer value. More...
 
ON_2dPointAt (int)
 At(index) returns nullptr if index < 0 or index >= count. More...
 
const ON_2dPointAt (int) const
 
ON_2dPointAt (ON__INT64)
 
const ON_2dPointAt (ON__INT64) const
 
ON_2dPointAt (ON__UINT64)
 
const ON_2dPointAt (ON__UINT64) const
 
ON_2dPointAt (unsigned int)
 
const ON_2dPointAt (unsigned int) const
 
int BinarySearch (const ON_2dPoint *, int(*)(const ON_2dPoint *, const ON_2dPoint *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
int BinarySearch (const ON_2dPoint *, int(*)(const ON_2dPoint *, const ON_2dPoint *), int) const
 
const ON_2dPointBinarySearchPtr (const ON_2dPoint *, int(*)(const ON_2dPoint *, const ON_2dPoint *)) const
 
const ON_2dPointBinarySearchPtr (const ON_2dPoint *, int(*)(const ON_2dPoint *, const ON_2dPoint *), int) const
 
int Capacity () const
 capacity of array More...
 
int Count () const
 query /////////////////////////////////////////////////////////////// More...
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const
 
void Destroy ()
 onfree any memory and set count and capacity to zero More...
 
void EmergencyDestroy (void)
 emergency bailout /////////////////////////////////////////////////// More...
 
void Empty ()
 Sets count to 0, leaves capacity untouched. More...
 
ON_2dPointFirst ()
 
const ON_2dPointFirst () const
 returns nullptr if count = 0 More...
 
bool HeapSort (int(*)(const ON_2dPoint *, const ON_2dPoint *))
 
void Insert (int, const ON_2dPoint &)
 
int InsertInSortedList (const ON_2dPoint &, int(*)(const ON_2dPoint *, const ON_2dPoint *))
 
int InsertInSortedList (const ON_2dPoint &, int(*)(const ON_2dPoint *, const ON_2dPoint *), int)
 
ON_2dPointKeepArray ()
 
ON_2dPointLast ()
 
const ON_2dPointLast () const
 returns nullptr if count = 0 More...
 
void MemSet (unsigned char)
 
int NewCapacity () const
 
 operator const ON_2dPoint * () const
 
 operator ON_2dPoint * ()
 The cast operators return a pointer. More...
 
ON_SimpleArray< ON_2dPoint > & operator= (const ON_SimpleArray< ON_2dPoint > &)
 
ON_2dPointoperator[] (int)
 
const ON_2dPointoperator[] (int) const
 
ON_2dPointoperator[] (ON__INT64)
 
const ON_2dPointoperator[] (ON__INT64) const
 
ON_2dPointoperator[] (ON__UINT64)
 
const ON_2dPointoperator[] (ON__UINT64) const
 
ON_2dPointoperator[] (unsigned int)
 
const ON_2dPointoperator[] (unsigned int) const
 
bool Permute (const int *)
 
void Prepend (int, const ON_2dPoint *)
 Prepend copy of an array T[count]. More...
 
bool QuickSort (int(*)(const ON_2dPoint *, const ON_2dPoint *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
bool QuickSortAndRemoveDuplicates (int(*)(const ON_2dPoint *, const ON_2dPoint *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
virtual ON_2dPointRealloc (ON_2dPoint *, int)
 low level memory management ////////////////////////////////////////// More...
 
void Remove ()
 
virtual void Remove (int)
 
void RemoveIf (bool predicate(const ON_2dPoint &key))
 
void RemoveValue (const ON_2dPoint &)
 
ON_2dPointReserve (size_t)
 memory management //////////////////////////////////////////////////// More...
 
void Reverse ()
 reverse order More...
 
int Search (const ON_2dPoint &) const
 
int Search (const ON_2dPoint *, int(*)(const ON_2dPoint *, const ON_2dPoint *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
void SetArray (ON_2dPoint *)
 
void SetArray (ON_2dPoint *, int, int)
 
ON_2dPointSetCapacity (size_t)
 
void SetCount (int)
 low level memory management ////////////////////////////////////////// More...
 
void SetRange (int from, int count, ON_2dPoint)
 
void Shrink ()
 remove unused capacity More...
 
unsigned int SizeOfArray () const
 amount of memory in the m_a[] array More...
 
unsigned int SizeOfElement () const
 amount of memory in an m_a[] array element More...
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_2dPoint *, const ON_2dPoint *)) const
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_2dPoint *, const ON_2dPoint *, void *), void *) const
 
void Swap (int, int)
 swap elements i and j More...
 
unsigned int UnsignedCount () const
 
void Zero ()
 

Additional Inherited Members

- Protected Member Functions inherited from ON_SimpleArray< ON_2dPoint >
void Move (int, int, int)
 implementation ////////////////////////////////////////////////////// More...
 
- Protected Attributes inherited from ON_SimpleArray< ON_2dPoint >
ON_2dPointm_a
 pointer to array memory More...
 
int m_capacity
 actual length of m_a[] More...
 
int m_count
 0 <= m_count <= m_capacity More...
 

Constructor & Destructor Documentation

◆ ON_2dPointArray() [1/3]

ON_2dPointArray::ON_2dPointArray ( )

see ON_SimpleArray class definition comments for constructor documentation

◆ ON_2dPointArray() [2/3]

ON_2dPointArray::ON_2dPointArray ( int  )

◆ ON_2dPointArray() [3/3]

ON_2dPointArray::ON_2dPointArray ( const ON_2dPointArray )

Member Function Documentation

◆ GetBBox()

bool ON_2dPointArray::GetBBox ( double  boxmin[2],
double  boxmax[2],
bool  bGrowBox = false 
) const
Parameters
boxminreturns true if successful
bGrowBoxtrue means grow box

◆ operator=()

ON_2dPointArray& ON_2dPointArray::operator= ( const ON_2dPointArray )

◆ SwapCoordinates()

bool ON_2dPointArray::SwapCoordinates ( int  ,
int   
)

◆ Transform()

bool ON_2dPointArray::Transform ( const ON_Xform )