Rhino C++ API  8.5
Public Member Functions | List of all members
ON_2dVectorArray Class Reference

#include <opennurbs_point.h>

Inheritance diagram for ON_2dVectorArray:
ON_SimpleArray< ON_2dVector >

Public Member Functions

 ON_2dVectorArray ()
 see ON_SimpleArray class definition comments for constructor documentation More...
 
 ON_2dVectorArray (const ON_2dVectorArray &)
 
 ON_2dVectorArray (int)
 
bool GetBBox (double boxmin[2], double boxmax[2], bool bGrowBox=false) const
 
ON_2dVectorArrayoperator= (const ON_2dVectorArray &)
 
bool SwapCoordinates (int, int)
 
bool Transform (const ON_Xform &)
 
- Public Member Functions inherited from ON_SimpleArray< ON_2dVector >
 ON_SimpleArray () ON_NOEXCEPT
 construction //////////////////////////////////////////////////////// More...
 
 ON_SimpleArray (const ON_SimpleArray< ON_2dVector > &)
 Copy constructor. More...
 
 ON_SimpleArray (size_t)
 size_t parameter = initial capacity More...
 
virtual ~ON_SimpleArray ()
 
void Append (const ON_2dVector &)
 
void Append (int, const ON_2dVector *)
 Append copy of an array T[count]. More...
 
ON_2dVectorAppendNew ()
 array operations //////////////////////////////////////////////////// More...
 
ON_2dVectorArray ()
 The Array() function return the. More...
 
const ON_2dVectorArray () const
 m_a pointer value. More...
 
ON_2dVectorAt (int)
 At(index) returns nullptr if index < 0 or index >= count. More...
 
const ON_2dVectorAt (int) const
 
ON_2dVectorAt (ON__INT64)
 
const ON_2dVectorAt (ON__INT64) const
 
ON_2dVectorAt (ON__UINT64)
 
const ON_2dVectorAt (ON__UINT64) const
 
ON_2dVectorAt (unsigned int)
 
const ON_2dVectorAt (unsigned int) const
 
int BinarySearch (const ON_2dVector *, int(*)(const ON_2dVector *, const ON_2dVector *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
int BinarySearch (const ON_2dVector *, int(*)(const ON_2dVector *, const ON_2dVector *), int) const
 
const ON_2dVectorBinarySearchPtr (const ON_2dVector *, int(*)(const ON_2dVector *, const ON_2dVector *)) const
 
const ON_2dVectorBinarySearchPtr (const ON_2dVector *, int(*)(const ON_2dVector *, const ON_2dVector *), int) const
 
int Capacity () const
 capacity of array More...
 
int Count () const
 query /////////////////////////////////////////////////////////////// More...
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const
 
void Destroy ()
 onfree any memory and set count and capacity to zero More...
 
void EmergencyDestroy (void)
 emergency bailout /////////////////////////////////////////////////// More...
 
void Empty ()
 Sets count to 0, leaves capacity untouched. More...
 
ON_2dVectorFirst ()
 
const ON_2dVectorFirst () const
 returns nullptr if count = 0 More...
 
bool HeapSort (int(*)(const ON_2dVector *, const ON_2dVector *))
 
void Insert (int, const ON_2dVector &)
 
int InsertInSortedList (const ON_2dVector &, int(*)(const ON_2dVector *, const ON_2dVector *))
 
int InsertInSortedList (const ON_2dVector &, int(*)(const ON_2dVector *, const ON_2dVector *), int)
 
ON_2dVectorKeepArray ()
 
ON_2dVectorLast ()
 
const ON_2dVectorLast () const
 returns nullptr if count = 0 More...
 
void MemSet (unsigned char)
 
int NewCapacity () const
 
 operator const ON_2dVector * () const
 
 operator ON_2dVector * ()
 The cast operators return a pointer. More...
 
ON_SimpleArray< ON_2dVector > & operator= (const ON_SimpleArray< ON_2dVector > &)
 
ON_2dVectoroperator[] (int)
 
const ON_2dVectoroperator[] (int) const
 
ON_2dVectoroperator[] (ON__INT64)
 
const ON_2dVectoroperator[] (ON__INT64) const
 
ON_2dVectoroperator[] (ON__UINT64)
 
const ON_2dVectoroperator[] (ON__UINT64) const
 
ON_2dVectoroperator[] (unsigned int)
 
const ON_2dVectoroperator[] (unsigned int) const
 
bool Permute (const int *)
 
void Prepend (int, const ON_2dVector *)
 Prepend copy of an array T[count]. More...
 
bool QuickSort (int(*)(const ON_2dVector *, const ON_2dVector *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
bool QuickSortAndRemoveDuplicates (int(*)(const ON_2dVector *, const ON_2dVector *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
virtual ON_2dVectorRealloc (ON_2dVector *, int)
 low level memory management ////////////////////////////////////////// More...
 
void Remove ()
 
virtual void Remove (int)
 
void RemoveIf (bool predicate(const ON_2dVector &key))
 
void RemoveValue (const ON_2dVector &)
 
ON_2dVectorReserve (size_t)
 memory management //////////////////////////////////////////////////// More...
 
void Reverse ()
 reverse order More...
 
int Search (const ON_2dVector &) const
 
int Search (const ON_2dVector *, int(*)(const ON_2dVector *, const ON_2dVector *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
void SetArray (ON_2dVector *)
 
void SetArray (ON_2dVector *, int, int)
 
ON_2dVectorSetCapacity (size_t)
 
void SetCount (int)
 low level memory management ////////////////////////////////////////// More...
 
void SetRange (int from, int count, ON_2dVector)
 
void Shrink ()
 remove unused capacity More...
 
unsigned int SizeOfArray () const
 amount of memory in the m_a[] array More...
 
unsigned int SizeOfElement () const
 amount of memory in an m_a[] array element More...
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_2dVector *, const ON_2dVector *)) const
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_2dVector *, const ON_2dVector *, void *), void *) const
 
void Swap (int, int)
 swap elements i and j More...
 
unsigned int UnsignedCount () const
 
void Zero ()
 

Additional Inherited Members

- Protected Member Functions inherited from ON_SimpleArray< ON_2dVector >
void Move (int, int, int)
 implementation ////////////////////////////////////////////////////// More...
 
- Protected Attributes inherited from ON_SimpleArray< ON_2dVector >
ON_2dVectorm_a
 pointer to array memory More...
 
int m_capacity
 actual length of m_a[] More...
 
int m_count
 0 <= m_count <= m_capacity More...
 

Constructor & Destructor Documentation

◆ ON_2dVectorArray() [1/3]

ON_2dVectorArray::ON_2dVectorArray ( )

see ON_SimpleArray class definition comments for constructor documentation

◆ ON_2dVectorArray() [2/3]

ON_2dVectorArray::ON_2dVectorArray ( int  )

◆ ON_2dVectorArray() [3/3]

ON_2dVectorArray::ON_2dVectorArray ( const ON_2dVectorArray )

Member Function Documentation

◆ GetBBox()

bool ON_2dVectorArray::GetBBox ( double  boxmin[2],
double  boxmax[2],
bool  bGrowBox = false 
) const

◆ operator=()

ON_2dVectorArray& ON_2dVectorArray::operator= ( const ON_2dVectorArray )

◆ SwapCoordinates()

bool ON_2dVectorArray::SwapCoordinates ( int  ,
int   
)

◆ Transform()

bool ON_2dVectorArray::Transform ( const ON_Xform )