Rhino C++ API  8.6
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_2udex Class Reference

#include <opennurbs_defines.h>

Public Member Functions

 ON_2udex ()=default
 
 ON_2udex (const ON_2udex &)=default
 
 ON_2udex (unsigned int i, unsigned int j)
 
 ~ON_2udex ()=default
 
ON_2udex AsDecreasing () const
 return a copy of this item, where i is larger or equal to j More...
 
ON_2udex AsIncreasing () const
 return a copy of this item, where i is smaller or equal to j More...
 
bool operator!= (const ON_2udex &src) const
 
bool operator< (const ON_2udex &src) const
 
bool operator<= (const ON_2udex &src) const
 
ON_2udexoperator= (const ON_2udex &)=default
 
bool operator== (const ON_2udex &src) const
 
bool operator> (const ON_2udex &src) const
 
bool operator>= (const ON_2udex &src) const
 

Static Public Member Functions

static int CompareFirstIndex (const ON_2udex *lhs, const ON_2udex *rhs)
 
static int CompareSecondIndex (const ON_2udex *lhs, const ON_2udex *rhs)
 
static int DictionaryCompare (const ON_2udex *lhs, const ON_2udex *rhs)
 

Public Attributes

unsigned int i
 do not initialize i, j for performance reasons More...
 
unsigned int j
 

Static Public Attributes

static const ON_2udex Unset
 (ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX); More...
 
static const ON_2udex Zero
 (0, 0) More...
 

Constructor & Destructor Documentation

◆ ON_2udex() [1/3]

ON_2udex::ON_2udex ( )
default

◆ ~ON_2udex()

ON_2udex::~ON_2udex ( )
default

◆ ON_2udex() [2/3]

ON_2udex::ON_2udex ( const ON_2udex )
default

◆ ON_2udex() [3/3]

ON_2udex::ON_2udex ( unsigned int  i,
unsigned int  j 
)

Member Function Documentation

◆ AsDecreasing()

ON_2udex ON_2udex::AsDecreasing ( ) const

return a copy of this item, where i is larger or equal to j

◆ AsIncreasing()

ON_2udex ON_2udex::AsIncreasing ( ) const

return a copy of this item, where i is smaller or equal to j

◆ CompareFirstIndex()

static int ON_2udex::CompareFirstIndex ( const ON_2udex lhs,
const ON_2udex rhs 
)
static

◆ CompareSecondIndex()

static int ON_2udex::CompareSecondIndex ( const ON_2udex lhs,
const ON_2udex rhs 
)
static

◆ DictionaryCompare()

static int ON_2udex::DictionaryCompare ( const ON_2udex lhs,
const ON_2udex rhs 
)
static

◆ operator!=()

bool ON_2udex::operator!= ( const ON_2udex src) const

◆ operator<()

bool ON_2udex::operator< ( const ON_2udex src) const

◆ operator<=()

bool ON_2udex::operator<= ( const ON_2udex src) const

◆ operator=()

ON_2udex& ON_2udex::operator= ( const ON_2udex )
default

◆ operator==()

bool ON_2udex::operator== ( const ON_2udex src) const

◆ operator>()

bool ON_2udex::operator> ( const ON_2udex src) const

◆ operator>=()

bool ON_2udex::operator>= ( const ON_2udex src) const

Member Data Documentation

◆ i

unsigned int ON_2udex::i

do not initialize i, j for performance reasons

◆ j

unsigned int ON_2udex::j

◆ Unset

const ON_2udex ON_2udex::Unset
static

(ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX);

◆ Zero

const ON_2udex ON_2udex::Zero
static

(0, 0)