#include <opennurbs_archive.h>
◆ TableState
Enumerator |
---|
Unset | |
Started | began to read the table
|
InProgress | |
Finished | finished reading the table
|
NotFound | the table could not be located during reading
|
◆ ON_3dmArchiveTableStatus() [1/2]
ON_3dmArchiveTableStatus::ON_3dmArchiveTableStatus |
( |
| ) |
|
|
default |
◆ ~ON_3dmArchiveTableStatus()
ON_3dmArchiveTableStatus::~ON_3dmArchiveTableStatus |
( |
| ) |
|
|
default |
◆ ON_3dmArchiveTableStatus() [2/2]
◆ operator=()
◆ m_crc_error_count
unsigned int ON_3dmArchiveTableStatus::m_crc_error_count = 0 |
Number of crc errors found during archive reading. If > 0, then the archive is corrupt. See the table status information below to determine where the errors occurred.
◆ m_critical_error_count
unsigned int ON_3dmArchiveTableStatus::m_critical_error_count = 0 |
Number of other types of serious errors found during archive reading or writing. If > 0, then the archive is corrupt. See the table status information below to determine where the errors occurred.
◆ m_item_count
unsigned int ON_3dmArchiveTableStatus::m_item_count = 0 |
◆ m_recoverable_error_count
unsigned int ON_3dmArchiveTableStatus::m_recoverable_error_count = 0 |
Number of other types of serious errors found during archive reading. If > 0, then the archive is corrupt. See the table status information below to determine where the errors occurred.
◆ m_state
◆ m_table_type
◆ Unset