Rhino C++ API  8.6
Public Member Functions | List of all members
ON_3fPointArray Class Reference

#include <opennurbs_point.h>

Inheritance diagram for ON_3fPointArray:
ON_SimpleArray< ON_3fPoint >

Public Member Functions

 ON_3fPointArray ()
 see ON_SimpleArray class definition comments for constructor documentation More...
 
 ON_3fPointArray (const ON_3fPointArray &)
 
 ON_3fPointArray (int)
 
bool GetBBox (float boxmin[3], float boxmax[3], bool bGrowBox=false) const
 
ON_3fPointArrayoperator= (const ON_3fPointArray &)
 
bool SwapCoordinates (int, int)
 
bool Transform (const ON_Xform &)
 
- Public Member Functions inherited from ON_SimpleArray< ON_3fPoint >
 ON_SimpleArray () ON_NOEXCEPT
 construction //////////////////////////////////////////////////////// More...
 
 ON_SimpleArray (const ON_SimpleArray< ON_3fPoint > &)
 Copy constructor. More...
 
 ON_SimpleArray (size_t)
 size_t parameter = initial capacity More...
 
virtual ~ON_SimpleArray ()
 
void Append (const ON_3fPoint &)
 
void Append (int, const ON_3fPoint *)
 Append copy of an array T[count]. More...
 
ON_3fPointAppendNew ()
 array operations //////////////////////////////////////////////////// More...
 
ON_3fPointArray ()
 The Array() function return the. More...
 
const ON_3fPointArray () const
 m_a pointer value. More...
 
ON_3fPointAt (int)
 At(index) returns nullptr if index < 0 or index >= count. More...
 
const ON_3fPointAt (int) const
 
ON_3fPointAt (ON__INT64)
 
const ON_3fPointAt (ON__INT64) const
 
ON_3fPointAt (ON__UINT64)
 
const ON_3fPointAt (ON__UINT64) const
 
ON_3fPointAt (unsigned int)
 
const ON_3fPointAt (unsigned int) const
 
int BinarySearch (const ON_3fPoint *, int(*)(const ON_3fPoint *, const ON_3fPoint *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
int BinarySearch (const ON_3fPoint *, int(*)(const ON_3fPoint *, const ON_3fPoint *), int) const
 
const ON_3fPointBinarySearchPtr (const ON_3fPoint *, int(*)(const ON_3fPoint *, const ON_3fPoint *)) const
 
const ON_3fPointBinarySearchPtr (const ON_3fPoint *, int(*)(const ON_3fPoint *, const ON_3fPoint *), int) const
 
int Capacity () const
 capacity of array More...
 
int Count () const
 query /////////////////////////////////////////////////////////////// More...
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const
 
void Destroy ()
 onfree any memory and set count and capacity to zero More...
 
void EmergencyDestroy (void)
 emergency bailout /////////////////////////////////////////////////// More...
 
void Empty ()
 Sets count to 0, leaves capacity untouched. More...
 
ON_3fPointFirst ()
 
const ON_3fPointFirst () const
 returns nullptr if count = 0 More...
 
bool HeapSort (int(*)(const ON_3fPoint *, const ON_3fPoint *))
 
void Insert (int, const ON_3fPoint &)
 
int InsertInSortedList (const ON_3fPoint &, int(*)(const ON_3fPoint *, const ON_3fPoint *))
 
int InsertInSortedList (const ON_3fPoint &, int(*)(const ON_3fPoint *, const ON_3fPoint *), int)
 
ON_3fPointKeepArray ()
 
ON_3fPointLast ()
 
const ON_3fPointLast () const
 returns nullptr if count = 0 More...
 
void MemSet (unsigned char)
 
int NewCapacity () const
 
 operator const ON_3fPoint * () const
 
 operator ON_3fPoint * ()
 The cast operators return a pointer. More...
 
ON_SimpleArray< ON_3fPoint > & operator= (const ON_SimpleArray< ON_3fPoint > &)
 
ON_3fPointoperator[] (int)
 
const ON_3fPointoperator[] (int) const
 
ON_3fPointoperator[] (ON__INT64)
 
const ON_3fPointoperator[] (ON__INT64) const
 
ON_3fPointoperator[] (ON__UINT64)
 
const ON_3fPointoperator[] (ON__UINT64) const
 
ON_3fPointoperator[] (unsigned int)
 
const ON_3fPointoperator[] (unsigned int) const
 
bool Permute (const int *)
 
void Prepend (int, const ON_3fPoint *)
 Prepend copy of an array T[count]. More...
 
bool QuickSort (int(*)(const ON_3fPoint *, const ON_3fPoint *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
bool QuickSortAndRemoveDuplicates (int(*)(const ON_3fPoint *, const ON_3fPoint *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
virtual ON_3fPointRealloc (ON_3fPoint *, int)
 low level memory management ////////////////////////////////////////// More...
 
void Remove ()
 
virtual void Remove (int)
 
void RemoveIf (bool predicate(const ON_3fPoint &key))
 
void RemoveValue (const ON_3fPoint &)
 
ON_3fPointReserve (size_t)
 memory management //////////////////////////////////////////////////// More...
 
void Reverse ()
 reverse order More...
 
int Search (const ON_3fPoint &) const
 
int Search (const ON_3fPoint *, int(*)(const ON_3fPoint *, const ON_3fPoint *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
void SetArray (ON_3fPoint *)
 
void SetArray (ON_3fPoint *, int, int)
 
ON_3fPointSetCapacity (size_t)
 
void SetCount (int)
 low level memory management ////////////////////////////////////////// More...
 
void SetRange (int from, int count, ON_3fPoint)
 
void Shrink ()
 remove unused capacity More...
 
unsigned int SizeOfArray () const
 amount of memory in the m_a[] array More...
 
unsigned int SizeOfElement () const
 amount of memory in an m_a[] array element More...
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_3fPoint *, const ON_3fPoint *)) const
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_3fPoint *, const ON_3fPoint *, void *), void *) const
 
void Swap (int, int)
 swap elements i and j More...
 
unsigned int UnsignedCount () const
 
void Zero ()
 

Additional Inherited Members

- Protected Member Functions inherited from ON_SimpleArray< ON_3fPoint >
void Move (int, int, int)
 implementation ////////////////////////////////////////////////////// More...
 
- Protected Attributes inherited from ON_SimpleArray< ON_3fPoint >
ON_3fPointm_a
 pointer to array memory More...
 
int m_capacity
 actual length of m_a[] More...
 
int m_count
 0 <= m_count <= m_capacity More...
 

Constructor & Destructor Documentation

◆ ON_3fPointArray() [1/3]

ON_3fPointArray::ON_3fPointArray ( )

see ON_SimpleArray class definition comments for constructor documentation

◆ ON_3fPointArray() [2/3]

ON_3fPointArray::ON_3fPointArray ( int  )

◆ ON_3fPointArray() [3/3]

ON_3fPointArray::ON_3fPointArray ( const ON_3fPointArray )

Member Function Documentation

◆ GetBBox()

bool ON_3fPointArray::GetBBox ( float  boxmin[3],
float  boxmax[3],
bool  bGrowBox = false 
) const

◆ operator=()

ON_3fPointArray& ON_3fPointArray::operator= ( const ON_3fPointArray )

◆ SwapCoordinates()

bool ON_3fPointArray::SwapCoordinates ( int  ,
int   
)

◆ Transform()

bool ON_3fPointArray::Transform ( const ON_Xform )