Rhino C++ API  8.5
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_3udex Class Reference

#include <opennurbs_defines.h>

Public Member Functions

 ON_3udex ()=default
 
 ON_3udex (const ON_3udex &)=default
 
 ON_3udex (unsigned int i, unsigned int j, unsigned int k)
 
 ~ON_3udex ()=default
 
ON_3udexoperator= (const ON_3udex &)=default
 

Static Public Member Functions

static int CompareFirstAndSecondIndex (const ON_3udex *lhs, const ON_3udex *rhs)
 
static int CompareFirstIndex (const ON_3udex *lhs, const ON_3udex *rhs)
 
static int CompareSecondIndex (const ON_3udex *lhs, const ON_3udex *rhs)
 
static int CompareThirdIndex (const ON_3udex *lhs, const ON_3udex *rhs)
 
static int DictionaryCompare (const ON_3udex *lhs, const ON_3udex *rhs)
 

Public Attributes

unsigned int i
 do not initialize i, j, k for performance reasons More...
 
unsigned int j
 
unsigned int k
 

Static Public Attributes

static const ON_3udex Unset
 (ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX); More...
 
static const ON_3udex Zero
 (0, 0, 0) More...
 

Constructor & Destructor Documentation

◆ ON_3udex() [1/3]

ON_3udex::ON_3udex ( )
default

◆ ~ON_3udex()

ON_3udex::~ON_3udex ( )
default

◆ ON_3udex() [2/3]

ON_3udex::ON_3udex ( const ON_3udex )
default

◆ ON_3udex() [3/3]

ON_3udex::ON_3udex ( unsigned int  i,
unsigned int  j,
unsigned int  k 
)

Member Function Documentation

◆ CompareFirstAndSecondIndex()

static int ON_3udex::CompareFirstAndSecondIndex ( const ON_3udex lhs,
const ON_3udex rhs 
)
static

◆ CompareFirstIndex()

static int ON_3udex::CompareFirstIndex ( const ON_3udex lhs,
const ON_3udex rhs 
)
static

◆ CompareSecondIndex()

static int ON_3udex::CompareSecondIndex ( const ON_3udex lhs,
const ON_3udex rhs 
)
static

◆ CompareThirdIndex()

static int ON_3udex::CompareThirdIndex ( const ON_3udex lhs,
const ON_3udex rhs 
)
static

◆ DictionaryCompare()

static int ON_3udex::DictionaryCompare ( const ON_3udex lhs,
const ON_3udex rhs 
)
static

◆ operator=()

ON_3udex& ON_3udex::operator= ( const ON_3udex )
default

Member Data Documentation

◆ i

unsigned int ON_3udex::i

do not initialize i, j, k for performance reasons

◆ j

unsigned int ON_3udex::j

◆ k

unsigned int ON_3udex::k

◆ Unset

const ON_3udex ON_3udex::Unset
static

(ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX);

◆ Zero

const ON_3udex ON_3udex::Zero
static

(0, 0, 0)