Rhino C++ API  8.6
Public Member Functions | List of all members
ON_4dPointArray Class Reference

#include <opennurbs_point.h>

Inheritance diagram for ON_4dPointArray:
ON_SimpleArray< ON_4dPoint >

Public Member Functions

 ON_4dPointArray ()
 see ON_SimpleArray class definition comments for constructor documentation More...
 
 ON_4dPointArray (const ON_4dPointArray &)
 
 ON_4dPointArray (int)
 
ON_4dPointArrayoperator= (const ON_4dPointArray &)
 
bool SwapCoordinates (int, int)
 
bool Transform (const ON_Xform &)
 
- Public Member Functions inherited from ON_SimpleArray< ON_4dPoint >
 ON_SimpleArray () ON_NOEXCEPT
 construction //////////////////////////////////////////////////////// More...
 
 ON_SimpleArray (const ON_SimpleArray< ON_4dPoint > &)
 Copy constructor. More...
 
 ON_SimpleArray (size_t)
 size_t parameter = initial capacity More...
 
virtual ~ON_SimpleArray ()
 
void Append (const ON_4dPoint &)
 
void Append (int, const ON_4dPoint *)
 Append copy of an array T[count]. More...
 
ON_4dPointAppendNew ()
 array operations //////////////////////////////////////////////////// More...
 
ON_4dPointArray ()
 The Array() function return the. More...
 
const ON_4dPointArray () const
 m_a pointer value. More...
 
ON_4dPointAt (int)
 At(index) returns nullptr if index < 0 or index >= count. More...
 
const ON_4dPointAt (int) const
 
ON_4dPointAt (ON__INT64)
 
const ON_4dPointAt (ON__INT64) const
 
ON_4dPointAt (ON__UINT64)
 
const ON_4dPointAt (ON__UINT64) const
 
ON_4dPointAt (unsigned int)
 
const ON_4dPointAt (unsigned int) const
 
int BinarySearch (const ON_4dPoint *, int(*)(const ON_4dPoint *, const ON_4dPoint *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
int BinarySearch (const ON_4dPoint *, int(*)(const ON_4dPoint *, const ON_4dPoint *), int) const
 
const ON_4dPointBinarySearchPtr (const ON_4dPoint *, int(*)(const ON_4dPoint *, const ON_4dPoint *)) const
 
const ON_4dPointBinarySearchPtr (const ON_4dPoint *, int(*)(const ON_4dPoint *, const ON_4dPoint *), int) const
 
int Capacity () const
 capacity of array More...
 
int Count () const
 query /////////////////////////////////////////////////////////////// More...
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const
 
void Destroy ()
 onfree any memory and set count and capacity to zero More...
 
void EmergencyDestroy (void)
 emergency bailout /////////////////////////////////////////////////// More...
 
void Empty ()
 Sets count to 0, leaves capacity untouched. More...
 
ON_4dPointFirst ()
 
const ON_4dPointFirst () const
 returns nullptr if count = 0 More...
 
bool HeapSort (int(*)(const ON_4dPoint *, const ON_4dPoint *))
 
void Insert (int, const ON_4dPoint &)
 
int InsertInSortedList (const ON_4dPoint &, int(*)(const ON_4dPoint *, const ON_4dPoint *))
 
int InsertInSortedList (const ON_4dPoint &, int(*)(const ON_4dPoint *, const ON_4dPoint *), int)
 
ON_4dPointKeepArray ()
 
ON_4dPointLast ()
 
const ON_4dPointLast () const
 returns nullptr if count = 0 More...
 
void MemSet (unsigned char)
 
int NewCapacity () const
 
 operator const ON_4dPoint * () const
 
 operator ON_4dPoint * ()
 The cast operators return a pointer. More...
 
ON_SimpleArray< ON_4dPoint > & operator= (const ON_SimpleArray< ON_4dPoint > &)
 
ON_4dPointoperator[] (int)
 
const ON_4dPointoperator[] (int) const
 
ON_4dPointoperator[] (ON__INT64)
 
const ON_4dPointoperator[] (ON__INT64) const
 
ON_4dPointoperator[] (ON__UINT64)
 
const ON_4dPointoperator[] (ON__UINT64) const
 
ON_4dPointoperator[] (unsigned int)
 
const ON_4dPointoperator[] (unsigned int) const
 
bool Permute (const int *)
 
void Prepend (int, const ON_4dPoint *)
 Prepend copy of an array T[count]. More...
 
bool QuickSort (int(*)(const ON_4dPoint *, const ON_4dPoint *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
bool QuickSortAndRemoveDuplicates (int(*)(const ON_4dPoint *, const ON_4dPoint *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
virtual ON_4dPointRealloc (ON_4dPoint *, int)
 low level memory management ////////////////////////////////////////// More...
 
void Remove ()
 
virtual void Remove (int)
 
void RemoveIf (bool predicate(const ON_4dPoint &key))
 
void RemoveValue (const ON_4dPoint &)
 
ON_4dPointReserve (size_t)
 memory management //////////////////////////////////////////////////// More...
 
void Reverse ()
 reverse order More...
 
int Search (const ON_4dPoint &) const
 
int Search (const ON_4dPoint *, int(*)(const ON_4dPoint *, const ON_4dPoint *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
void SetArray (ON_4dPoint *)
 
void SetArray (ON_4dPoint *, int, int)
 
ON_4dPointSetCapacity (size_t)
 
void SetCount (int)
 low level memory management ////////////////////////////////////////// More...
 
void SetRange (int from, int count, ON_4dPoint)
 
void Shrink ()
 remove unused capacity More...
 
unsigned int SizeOfArray () const
 amount of memory in the m_a[] array More...
 
unsigned int SizeOfElement () const
 amount of memory in an m_a[] array element More...
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_4dPoint *, const ON_4dPoint *)) const
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_4dPoint *, const ON_4dPoint *, void *), void *) const
 
void Swap (int, int)
 swap elements i and j More...
 
unsigned int UnsignedCount () const
 
void Zero ()
 

Additional Inherited Members

- Protected Member Functions inherited from ON_SimpleArray< ON_4dPoint >
void Move (int, int, int)
 implementation ////////////////////////////////////////////////////// More...
 
- Protected Attributes inherited from ON_SimpleArray< ON_4dPoint >
ON_4dPointm_a
 pointer to array memory More...
 
int m_capacity
 actual length of m_a[] More...
 
int m_count
 0 <= m_count <= m_capacity More...
 

Constructor & Destructor Documentation

◆ ON_4dPointArray() [1/3]

ON_4dPointArray::ON_4dPointArray ( )

see ON_SimpleArray class definition comments for constructor documentation

◆ ON_4dPointArray() [2/3]

ON_4dPointArray::ON_4dPointArray ( int  )

◆ ON_4dPointArray() [3/3]

ON_4dPointArray::ON_4dPointArray ( const ON_4dPointArray )

Member Function Documentation

◆ operator=()

ON_4dPointArray& ON_4dPointArray::operator= ( const ON_4dPointArray )

◆ SwapCoordinates()

bool ON_4dPointArray::SwapCoordinates ( int  ,
int   
)

◆ Transform()

bool ON_4dPointArray::Transform ( const ON_Xform )