Rhino C++ API  8.5
Public Member Functions | List of all members
ON_4fPointArray Class Reference

#include <opennurbs_point.h>

Inheritance diagram for ON_4fPointArray:
ON_SimpleArray< ON_4fPoint >

Public Member Functions

 ON_4fPointArray ()
 see ON_SimpleArray class definition comments for constructor documentation More...
 
 ON_4fPointArray (const ON_4fPointArray &)
 
 ON_4fPointArray (int)
 
ON_4fPointArrayoperator= (const ON_4fPointArray &)
 
bool SwapCoordinates (int, int)
 
bool Transform (const ON_Xform &)
 
- Public Member Functions inherited from ON_SimpleArray< ON_4fPoint >
 ON_SimpleArray () ON_NOEXCEPT
 construction //////////////////////////////////////////////////////// More...
 
 ON_SimpleArray (const ON_SimpleArray< ON_4fPoint > &)
 Copy constructor. More...
 
 ON_SimpleArray (size_t)
 size_t parameter = initial capacity More...
 
virtual ~ON_SimpleArray ()
 
void Append (const ON_4fPoint &)
 
void Append (int, const ON_4fPoint *)
 Append copy of an array T[count]. More...
 
ON_4fPointAppendNew ()
 array operations //////////////////////////////////////////////////// More...
 
ON_4fPointArray ()
 The Array() function return the. More...
 
const ON_4fPointArray () const
 m_a pointer value. More...
 
ON_4fPointAt (int)
 At(index) returns nullptr if index < 0 or index >= count. More...
 
const ON_4fPointAt (int) const
 
ON_4fPointAt (ON__INT64)
 
const ON_4fPointAt (ON__INT64) const
 
ON_4fPointAt (ON__UINT64)
 
const ON_4fPointAt (ON__UINT64) const
 
ON_4fPointAt (unsigned int)
 
const ON_4fPointAt (unsigned int) const
 
int BinarySearch (const ON_4fPoint *, int(*)(const ON_4fPoint *, const ON_4fPoint *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
int BinarySearch (const ON_4fPoint *, int(*)(const ON_4fPoint *, const ON_4fPoint *), int) const
 
const ON_4fPointBinarySearchPtr (const ON_4fPoint *, int(*)(const ON_4fPoint *, const ON_4fPoint *)) const
 
const ON_4fPointBinarySearchPtr (const ON_4fPoint *, int(*)(const ON_4fPoint *, const ON_4fPoint *), int) const
 
int Capacity () const
 capacity of array More...
 
int Count () const
 query /////////////////////////////////////////////////////////////// More...
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const
 
void Destroy ()
 onfree any memory and set count and capacity to zero More...
 
void EmergencyDestroy (void)
 emergency bailout /////////////////////////////////////////////////// More...
 
void Empty ()
 Sets count to 0, leaves capacity untouched. More...
 
ON_4fPointFirst ()
 
const ON_4fPointFirst () const
 returns nullptr if count = 0 More...
 
bool HeapSort (int(*)(const ON_4fPoint *, const ON_4fPoint *))
 
void Insert (int, const ON_4fPoint &)
 
int InsertInSortedList (const ON_4fPoint &, int(*)(const ON_4fPoint *, const ON_4fPoint *))
 
int InsertInSortedList (const ON_4fPoint &, int(*)(const ON_4fPoint *, const ON_4fPoint *), int)
 
ON_4fPointKeepArray ()
 
ON_4fPointLast ()
 
const ON_4fPointLast () const
 returns nullptr if count = 0 More...
 
void MemSet (unsigned char)
 
int NewCapacity () const
 
 operator const ON_4fPoint * () const
 
 operator ON_4fPoint * ()
 The cast operators return a pointer. More...
 
ON_SimpleArray< ON_4fPoint > & operator= (const ON_SimpleArray< ON_4fPoint > &)
 
ON_4fPointoperator[] (int)
 
const ON_4fPointoperator[] (int) const
 
ON_4fPointoperator[] (ON__INT64)
 
const ON_4fPointoperator[] (ON__INT64) const
 
ON_4fPointoperator[] (ON__UINT64)
 
const ON_4fPointoperator[] (ON__UINT64) const
 
ON_4fPointoperator[] (unsigned int)
 
const ON_4fPointoperator[] (unsigned int) const
 
bool Permute (const int *)
 
void Prepend (int, const ON_4fPoint *)
 Prepend copy of an array T[count]. More...
 
bool QuickSort (int(*)(const ON_4fPoint *, const ON_4fPoint *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
bool QuickSortAndRemoveDuplicates (int(*)(const ON_4fPoint *, const ON_4fPoint *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
virtual ON_4fPointRealloc (ON_4fPoint *, int)
 low level memory management ////////////////////////////////////////// More...
 
void Remove ()
 
virtual void Remove (int)
 
void RemoveIf (bool predicate(const ON_4fPoint &key))
 
void RemoveValue (const ON_4fPoint &)
 
ON_4fPointReserve (size_t)
 memory management //////////////////////////////////////////////////// More...
 
void Reverse ()
 reverse order More...
 
int Search (const ON_4fPoint &) const
 
int Search (const ON_4fPoint *, int(*)(const ON_4fPoint *, const ON_4fPoint *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
void SetArray (ON_4fPoint *)
 
void SetArray (ON_4fPoint *, int, int)
 
ON_4fPointSetCapacity (size_t)
 
void SetCount (int)
 low level memory management ////////////////////////////////////////// More...
 
void SetRange (int from, int count, ON_4fPoint)
 
void Shrink ()
 remove unused capacity More...
 
unsigned int SizeOfArray () const
 amount of memory in the m_a[] array More...
 
unsigned int SizeOfElement () const
 amount of memory in an m_a[] array element More...
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_4fPoint *, const ON_4fPoint *)) const
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_4fPoint *, const ON_4fPoint *, void *), void *) const
 
void Swap (int, int)
 swap elements i and j More...
 
unsigned int UnsignedCount () const
 
void Zero ()
 

Additional Inherited Members

- Protected Member Functions inherited from ON_SimpleArray< ON_4fPoint >
void Move (int, int, int)
 implementation ////////////////////////////////////////////////////// More...
 
- Protected Attributes inherited from ON_SimpleArray< ON_4fPoint >
ON_4fPointm_a
 pointer to array memory More...
 
int m_capacity
 actual length of m_a[] More...
 
int m_count
 0 <= m_count <= m_capacity More...
 

Constructor & Destructor Documentation

◆ ON_4fPointArray() [1/3]

ON_4fPointArray::ON_4fPointArray ( )

see ON_SimpleArray class definition comments for constructor documentation

◆ ON_4fPointArray() [2/3]

ON_4fPointArray::ON_4fPointArray ( int  )

◆ ON_4fPointArray() [3/3]

ON_4fPointArray::ON_4fPointArray ( const ON_4fPointArray )

Member Function Documentation

◆ operator=()

ON_4fPointArray& ON_4fPointArray::operator= ( const ON_4fPointArray )

◆ SwapCoordinates()

bool ON_4fPointArray::SwapCoordinates ( int  ,
int   
)

◆ Transform()

bool ON_4fPointArray::Transform ( const ON_Xform )