Rhino C++ API  8.5
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_4udex Class Reference

#include <opennurbs_defines.h>

Public Member Functions

 ON_4udex ()=default
 
 ON_4udex (const ON_4udex &)=default
 
 ON_4udex (unsigned int i, unsigned int j, unsigned int k, unsigned int l)
 
 ~ON_4udex ()=default
 
ON_4udex AsIncreasing () const
 return a copy, where i is smaller or equal to j, j is smaller or equal to k, and k is smaller or equal to l More...
 
ON_4udex AsPairwiseIncreasing () const
 return a copy, where i is smaller or equal to k; if they are equal, j is smaller or equal to l More...
 
bool operator!= (const ON_4udex &src) const
 
ON_4udexoperator= (const ON_4udex &)=default
 
bool operator== (const ON_4udex &src) const
 

Public Attributes

unsigned int i
 do not initialize i, j, k, l for performance reasons More...
 
unsigned int j
 
unsigned int k
 
unsigned int l
 

Static Public Attributes

static const ON_4udex Unset
 (ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX); More...
 
static const ON_4udex Zero
 (0, 0, 0, 0) More...
 

Constructor & Destructor Documentation

◆ ON_4udex() [1/3]

ON_4udex::ON_4udex ( )
default

◆ ~ON_4udex()

ON_4udex::~ON_4udex ( )
default

◆ ON_4udex() [2/3]

ON_4udex::ON_4udex ( const ON_4udex )
default

◆ ON_4udex() [3/3]

ON_4udex::ON_4udex ( unsigned int  i,
unsigned int  j,
unsigned int  k,
unsigned int  l 
)

Member Function Documentation

◆ AsIncreasing()

ON_4udex ON_4udex::AsIncreasing ( ) const

return a copy, where i is smaller or equal to j, j is smaller or equal to k, and k is smaller or equal to l

◆ AsPairwiseIncreasing()

ON_4udex ON_4udex::AsPairwiseIncreasing ( ) const

return a copy, where i is smaller or equal to k; if they are equal, j is smaller or equal to l

◆ operator!=()

bool ON_4udex::operator!= ( const ON_4udex src) const

◆ operator=()

ON_4udex& ON_4udex::operator= ( const ON_4udex )
default

◆ operator==()

bool ON_4udex::operator== ( const ON_4udex src) const

Member Data Documentation

◆ i

unsigned int ON_4udex::i

do not initialize i, j, k, l for performance reasons

◆ j

unsigned int ON_4udex::j

◆ k

unsigned int ON_4udex::k

◆ l

unsigned int ON_4udex::l

◆ Unset

const ON_4udex ON_4udex::Unset
static

(ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX, ON_UNSET_UINT_INDEX);

◆ Zero

const ON_4udex ON_4udex::Zero
static

(0, 0, 0, 0)