Rhino C++ API
8.13
|
Curve/ImplicitFunction intersection event. More...
#include <opennurbs_plus_implicitfn.h>
Public Types | |
enum | AmbigType : int { AmbigType::Unknown = 0, AmbigType::Tangent = 1, AmbigType::TangentEnd = 2, AmbigType::Transverse = 3 } |
enum | Type : int { Type::Unknown = 0, Type::NoEvent = 1, Type::Point = 2, Type::Overlap = 3 } |
Public Member Functions | |
ON_CIXEvent () | |
Public Attributes | |
ON_Interval | m_domain |
ON_3dPoint | m_point |
Type | m_type |
Curve/ImplicitFunction intersection event.
|
strong |
|
strong |
|
inline |
ON_Interval ON_CIXEvent::m_domain |
the overlap interval [t0, t1] with t0 < t1 of the overlapping curve, or the point parameter t as [t, t]
ON_3dPoint ON_CIXEvent::m_point |
Type ON_CIXEvent::m_type |