Rhino C++ API
8.13
|
#include <opennurbs_archive.h>
Public Member Functions | |
ON_DebugWriteArchive () | |
~ON_DebugWriteArchive () | |
ON_BinaryArchive * | Archive () const |
const ON_wString & | FilePath () const |
unsigned int | Number () const |
the number of the archive or 0 More... | |
Opens a debug archive file Uses directory set by ON_SetDebugWriteObjectDirectory(const wchar_t* ). creates a file named "debug_file_nnnn.3dm" Example: ON_DebugWriteArchive debug; if(debug.m_Archive) ON_WriteArchive( *debug.m_Archive, geometry );
ON_DebugWriteArchive::ON_DebugWriteArchive | ( | ) |
Creates a file in N_DebugWriteObjectDirectory() and allocates archive to write to that file.
ON_DebugWriteArchive::~ON_DebugWriteArchive | ( | ) |
ON_BinaryArchive* ON_DebugWriteArchive::Archive | ( | ) | const |
check for nullptr before using Destructor closes archive and deletes it.
const ON_wString& ON_DebugWriteArchive::FilePath | ( | ) | const |
Name of the archive file. = .../debug_file_NNNNN.3dm where N = Number().
unsigned int ON_DebugWriteArchive::Number | ( | ) | const |
the number of the archive or 0