Rhino C++ API
8.13
|
#include <opennurbs_texture_mapping.h>
Public Member Functions | |
ON_GeometryFingerprint () | |
bool | Matches (const ON_GeometryFingerprint &b, const ON_Xform &bt, double tol) const |
bool | Read (ON_BinaryArchive &binary_archive) |
void | Transform (const ON_Xform &xform) |
bool | Write (ON_BinaryArchive &binary_archive) const |
void | Zero () |
Public Attributes | |
ON_WeightedAverageHash | m_edgeWAH |
ON_WeightedAverageHash | m_pointWAH |
unsigned int | m_topologyCRC |
ON_GeometryFingerprint::ON_GeometryFingerprint | ( | ) |
bool ON_GeometryFingerprint::Matches | ( | const ON_GeometryFingerprint & | b, |
const ON_Xform & | bt, | ||
double | tol | ||
) | const |
bool ON_GeometryFingerprint::Read | ( | ON_BinaryArchive & | binary_archive | ) |
void ON_GeometryFingerprint::Transform | ( | const ON_Xform & | xform | ) |
bool ON_GeometryFingerprint::Write | ( | ON_BinaryArchive & | binary_archive | ) | const |
void ON_GeometryFingerprint::Zero | ( | ) |
ON_WeightedAverageHash ON_GeometryFingerprint::m_edgeWAH |
ON_WeightedAverageHash ON_GeometryFingerprint::m_pointWAH |
unsigned int ON_GeometryFingerprint::m_topologyCRC |