Rhino C++ API
8.13
|
#include <opennurbs_nurbssurface.h>
Public Member Functions | |
ON_HermiteSurface () | |
ON_HermiteSurface (int u_count, int v_count) | |
Constructs a u_count by v_count grid. More... | |
~ON_HermiteSurface () | |
bool | Create (int u_count, int v_count) |
Constructs a u_count by v_count grid. More... | |
const ON_ClassArray< ON_SimpleArray< ON_3dPoint > > & | GridPoints () const |
Grid of points to interpolate. More... | |
bool | IsValid () const |
ON_NurbsSurface * | NurbsSurface (ON_NurbsSurface *pNurbsSurface=nullptr) |
Create an ON_NurbsSurface satisfying Hermite interpolation conditions at a grid of points. More... | |
ON_3dPoint | PointAt (int u, int v) const |
Grid of points to interpolate. More... | |
void | SetPointAt (int u, int v, const ON_3dPoint &point) |
void | SetTwistAt (int u, int v, const ON_3dVector &dir) |
void | SetUParameterAt (int u, double param) |
void | SetUTangentAt (int u, int v, const ON_3dVector &dir) |
void | SetVParameterAt (int v, double param) |
void | SetVTangentAt (int u, int v, const ON_3dVector &dir) |
ON_3dVector | TwistAt (int u, int v) const |
Grid of twist vectors (mixed second partial derivatives) to interpolate. More... | |
const ON_ClassArray< ON_SimpleArray< ON_3dVector > > & | Twists () const |
Grid of twist vectors (mixed second partial derivatives) to interpolate. More... | |
int | UCount () const |
Returns the number of parameters in the "u" direction. More... | |
double | UParameterAt (int u) const |
const ON_SimpleArray< double > & | UParameters () const |
The "u" parameters defining the grid of parameter values. More... | |
ON_3dVector | UTangentAt (int u, int v) const |
Grid of "u" tangent directions (actually first derivatives) to interpolate. More... | |
const ON_ClassArray< ON_SimpleArray< ON_3dVector > > & | UTangents () const |
Grid of "u" tangent directions (actually first derivatives) to interpolate. More... | |
int | VCount () const |
Returns the number of parameters in the "v" direction. More... | |
double | VParameterAt (int v) const |
const ON_SimpleArray< double > & | VParameters () const |
The "v" parameters defining the grid of parameter values. More... | |
ON_3dVector | VTangentAt (int u, int v) const |
Grid of "v" tangent directions (actually first derivatives) to interpolate. More... | |
const ON_ClassArray< ON_SimpleArray< ON_3dVector > > & | VTangents () const |
Grid of "v" tangent directions (actually first derivatives) to interpolate. More... | |
Description: Create an ON_NurbsSurface satisfying Hermite interpolation conditions at a grid of points. Remarks: See static ON_NurbsSurface::CreateHermiteSurface for details.
ON_HermiteSurface::ON_HermiteSurface | ( | ) |
ON_HermiteSurface::ON_HermiteSurface | ( | int | u_count, |
int | v_count | ||
) |
Constructs a u_count by v_count grid.
ON_HermiteSurface::~ON_HermiteSurface | ( | ) |
bool ON_HermiteSurface::Create | ( | int | u_count, |
int | v_count | ||
) |
Constructs a u_count by v_count grid.
const ON_ClassArray<ON_SimpleArray<ON_3dPoint> >& ON_HermiteSurface::GridPoints | ( | ) | const |
Grid of points to interpolate.
bool ON_HermiteSurface::IsValid | ( | ) | const |
ON_NurbsSurface* ON_HermiteSurface::NurbsSurface | ( | ON_NurbsSurface * | pNurbsSurface = nullptr | ) |
Create an ON_NurbsSurface satisfying Hermite interpolation conditions at a grid of points.
ON_3dPoint ON_HermiteSurface::PointAt | ( | int | u, |
int | v | ||
) | const |
Grid of points to interpolate.
void ON_HermiteSurface::SetPointAt | ( | int | u, |
int | v, | ||
const ON_3dPoint & | point | ||
) |
void ON_HermiteSurface::SetTwistAt | ( | int | u, |
int | v, | ||
const ON_3dVector & | dir | ||
) |
void ON_HermiteSurface::SetUParameterAt | ( | int | u, |
double | param | ||
) |
void ON_HermiteSurface::SetUTangentAt | ( | int | u, |
int | v, | ||
const ON_3dVector & | dir | ||
) |
void ON_HermiteSurface::SetVParameterAt | ( | int | v, |
double | param | ||
) |
void ON_HermiteSurface::SetVTangentAt | ( | int | u, |
int | v, | ||
const ON_3dVector & | dir | ||
) |
ON_3dVector ON_HermiteSurface::TwistAt | ( | int | u, |
int | v | ||
) | const |
Grid of twist vectors (mixed second partial derivatives) to interpolate.
const ON_ClassArray<ON_SimpleArray<ON_3dVector> >& ON_HermiteSurface::Twists | ( | ) | const |
Grid of twist vectors (mixed second partial derivatives) to interpolate.
int ON_HermiteSurface::UCount | ( | ) | const |
Returns the number of parameters in the "u" direction.
double ON_HermiteSurface::UParameterAt | ( | int | u | ) | const |
Specifies the "u" parameters defining the grid of parameter values. These parameters are strictly increasing.
const ON_SimpleArray<double>& ON_HermiteSurface::UParameters | ( | ) | const |
The "u" parameters defining the grid of parameter values.
ON_3dVector ON_HermiteSurface::UTangentAt | ( | int | u, |
int | v | ||
) | const |
Grid of "u" tangent directions (actually first derivatives) to interpolate.
const ON_ClassArray<ON_SimpleArray<ON_3dVector> >& ON_HermiteSurface::UTangents | ( | ) | const |
Grid of "u" tangent directions (actually first derivatives) to interpolate.
int ON_HermiteSurface::VCount | ( | ) | const |
Returns the number of parameters in the "v" direction.
double ON_HermiteSurface::VParameterAt | ( | int | v | ) | const |
Specifies the "v" parameters defining the grid of parameter values. These parameters are strictly increasing.
const ON_SimpleArray<double>& ON_HermiteSurface::VParameters | ( | ) | const |
The "v" parameters defining the grid of parameter values.
ON_3dVector ON_HermiteSurface::VTangentAt | ( | int | u, |
int | v | ||
) | const |
Grid of "v" tangent directions (actually first derivatives) to interpolate.
const ON_ClassArray<ON_SimpleArray<ON_3dVector> >& ON_HermiteSurface::VTangents | ( | ) | const |
Grid of "v" tangent directions (actually first derivatives) to interpolate.