Rhino C++ API  8.6
Public Member Functions | List of all members
ON_MMX_Polyline Class Reference

#include <opennurbs_plus.h>

Inheritance diagram for ON_MMX_Polyline:
ON_SimpleArray< ON_MMX_POINT >

Public Member Functions

 ON_MMX_Polyline ()
 see ON_SimpleArray class definition comments for constructor documentation More...
 
 ON_MMX_Polyline (const ON_SimpleArray< ON_MMX_POINT > &)
 
 ON_MMX_Polyline (int)
 
int Clean (double tolerance=0.0)
 
ON_MMX_Polylineoperator= (const ON_MMX_Polyline &)
 
- Public Member Functions inherited from ON_SimpleArray< ON_MMX_POINT >
 ON_SimpleArray () ON_NOEXCEPT
 construction //////////////////////////////////////////////////////// More...
 
 ON_SimpleArray (const ON_SimpleArray< ON_MMX_POINT > &)
 Copy constructor. More...
 
 ON_SimpleArray (size_t)
 size_t parameter = initial capacity More...
 
virtual ~ON_SimpleArray ()
 
void Append (const ON_MMX_POINT &)
 
void Append (int, const ON_MMX_POINT *)
 Append copy of an array T[count]. More...
 
ON_MMX_POINTAppendNew ()
 array operations //////////////////////////////////////////////////// More...
 
ON_MMX_POINTArray ()
 The Array() function return the. More...
 
const ON_MMX_POINTArray () const
 m_a pointer value. More...
 
ON_MMX_POINTAt (int)
 At(index) returns nullptr if index < 0 or index >= count. More...
 
const ON_MMX_POINTAt (int) const
 
ON_MMX_POINTAt (ON__INT64)
 
const ON_MMX_POINTAt (ON__INT64) const
 
ON_MMX_POINTAt (ON__UINT64)
 
const ON_MMX_POINTAt (ON__UINT64) const
 
ON_MMX_POINTAt (unsigned int)
 
const ON_MMX_POINTAt (unsigned int) const
 
int BinarySearch (const ON_MMX_POINT *, int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
int BinarySearch (const ON_MMX_POINT *, int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *), int) const
 
const ON_MMX_POINTBinarySearchPtr (const ON_MMX_POINT *, int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *)) const
 
const ON_MMX_POINTBinarySearchPtr (const ON_MMX_POINT *, int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *), int) const
 
int Capacity () const
 capacity of array More...
 
int Count () const
 query /////////////////////////////////////////////////////////////// More...
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const
 
void Destroy ()
 onfree any memory and set count and capacity to zero More...
 
void EmergencyDestroy (void)
 emergency bailout /////////////////////////////////////////////////// More...
 
void Empty ()
 Sets count to 0, leaves capacity untouched. More...
 
ON_MMX_POINTFirst ()
 
const ON_MMX_POINTFirst () const
 returns nullptr if count = 0 More...
 
bool HeapSort (int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *))
 
void Insert (int, const ON_MMX_POINT &)
 
int InsertInSortedList (const ON_MMX_POINT &, int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *))
 
int InsertInSortedList (const ON_MMX_POINT &, int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *), int)
 
ON_MMX_POINTKeepArray ()
 
ON_MMX_POINTLast ()
 
const ON_MMX_POINTLast () const
 returns nullptr if count = 0 More...
 
void MemSet (unsigned char)
 
int NewCapacity () const
 
 operator const ON_MMX_POINT * () const
 
 operator ON_MMX_POINT * ()
 The cast operators return a pointer. More...
 
ON_SimpleArray< ON_MMX_POINT > & operator= (const ON_SimpleArray< ON_MMX_POINT > &)
 
ON_MMX_POINToperator[] (int)
 
const ON_MMX_POINToperator[] (int) const
 
ON_MMX_POINToperator[] (ON__INT64)
 
const ON_MMX_POINToperator[] (ON__INT64) const
 
ON_MMX_POINToperator[] (ON__UINT64)
 
const ON_MMX_POINToperator[] (ON__UINT64) const
 
ON_MMX_POINToperator[] (unsigned int)
 
const ON_MMX_POINToperator[] (unsigned int) const
 
bool Permute (const int *)
 
void Prepend (int, const ON_MMX_POINT *)
 Prepend copy of an array T[count]. More...
 
bool QuickSort (int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
bool QuickSortAndRemoveDuplicates (int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
virtual ON_MMX_POINTRealloc (ON_MMX_POINT *, int)
 low level memory management ////////////////////////////////////////// More...
 
void Remove ()
 
virtual void Remove (int)
 
void RemoveIf (bool predicate(const ON_MMX_POINT &key))
 
void RemoveValue (const ON_MMX_POINT &)
 
ON_MMX_POINTReserve (size_t)
 memory management //////////////////////////////////////////////////// More...
 
void Reverse ()
 reverse order More...
 
int Search (const ON_MMX_POINT &) const
 
int Search (const ON_MMX_POINT *, int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
void SetArray (ON_MMX_POINT *)
 
void SetArray (ON_MMX_POINT *, int, int)
 
ON_MMX_POINTSetCapacity (size_t)
 
void SetCount (int)
 low level memory management ////////////////////////////////////////// More...
 
void SetRange (int from, int count, ON_MMX_POINT)
 
void Shrink ()
 remove unused capacity More...
 
unsigned int SizeOfArray () const
 amount of memory in the m_a[] array More...
 
unsigned int SizeOfElement () const
 amount of memory in an m_a[] array element More...
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *)) const
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_MMX_POINT *, const ON_MMX_POINT *, void *), void *) const
 
void Swap (int, int)
 swap elements i and j More...
 
unsigned int UnsignedCount () const
 
void Zero ()
 

Additional Inherited Members

- Protected Member Functions inherited from ON_SimpleArray< ON_MMX_POINT >
void Move (int, int, int)
 implementation ////////////////////////////////////////////////////// More...
 
- Protected Attributes inherited from ON_SimpleArray< ON_MMX_POINT >
ON_MMX_POINTm_a
 pointer to array memory More...
 
int m_capacity
 actual length of m_a[] More...
 
int m_count
 0 <= m_count <= m_capacity More...
 

Constructor & Destructor Documentation

◆ ON_MMX_Polyline() [1/3]

ON_MMX_Polyline::ON_MMX_Polyline ( )

see ON_SimpleArray class definition comments for constructor documentation

◆ ON_MMX_Polyline() [2/3]

ON_MMX_Polyline::ON_MMX_Polyline ( int  )

◆ ON_MMX_Polyline() [3/3]

ON_MMX_Polyline::ON_MMX_Polyline ( const ON_SimpleArray< ON_MMX_POINT > &  )

Member Function Documentation

◆ Clean()

int ON_MMX_Polyline::Clean ( double  tolerance = 0.0)

Description: Removes duplicate points that result in zero length segments. Parameters: tolerance - [in] tolerance used to check for duplicate points. Returns: Number of points removed. Remarks: If the distance between points polyline[i] and polyline[i+1] is <= tolerance, then the point with index (i+1) is removed.

◆ operator=()

ON_MMX_Polyline& ON_MMX_Polyline::operator= ( const ON_MMX_Polyline )