#include <opennurbs_mesh.h>
◆ ON_MeshNgonAllocator()
ON_MeshNgonAllocator::ON_MeshNgonAllocator |
( |
| ) |
|
◆ ~ON_MeshNgonAllocator()
ON_MeshNgonAllocator::~ON_MeshNgonAllocator |
( |
| ) |
|
◆ AllocateNgon()
ON_MeshNgon* ON_MeshNgonAllocator::AllocateNgon |
( |
unsigned int |
Vcount, |
|
|
unsigned int |
Fcount |
|
) |
| |
Parameters: Vcount - [in] >= 3 Fcount - [in] >= 0
◆ CopyNgon()
Description: Returns a copy of ngon. Parameters: ngon - [in] Returns: If
◆ DeallocateAllNgons()
void ON_MeshNgonAllocator::DeallocateAllNgons |
( |
| ) |
|
Description: Deallocate every n-gon managed by this allocator.
◆ DeallocateNgon()
bool ON_MeshNgonAllocator::DeallocateNgon |
( |
ON_MeshNgon * |
ngon | ) |
|
Parameters: ngon - in] An ngon pointer value that was previously returned by this allocator's AllocateNgon() or CopyNgon() function.
◆ ReallocateNgon()
ON_MeshNgon* ON_MeshNgonAllocator::ReallocateNgon |
( |
ON_MeshNgon * |
ngon, |
|
|
unsigned int |
Vcount, |
|
|
unsigned int |
Fcount |
|
) |
| |
Parameters: Vcount - [in] >= 3 Fcount - [in] >= 0