#include <opennurbs_font.h>
|
enum | Proximity : ON__UINT8 { Proximity::Unset = 0,
Proximity::OnFigure = 1,
Proximity::OffFigure = 2,
Proximity::Error = 15
} |
|
enum | Type : ON__UINT8 {
Type::Unset = 0,
Type::BeginFigureUnknown = 1,
Type::BeginFigureOpen = 2,
Type::BeginFigureClosed = 3,
Type::LineTo = 6,
Type::QuadraticBezierPoint = 7,
Type::CubicBezierPoint = 8,
Type::EndFigureOpen = 11,
Type::EndFigureClosed = 12,
Type::Error = 15
} |
|
◆ Proximity
Enumerator |
---|
Unset | |
OnFigure | The point is the beginning or end of a line or bezier segment in the figure.
|
OffFigure | The point is a bezier control point that may be off the figure.
|
Error | |
◆ Type
Enumerator |
---|
Unset | |
BeginFigureUnknown | Beginning of a figure
The open/closed state is unknown.
|
BeginFigureOpen | Marks the beginning of an open figure. (single stroke font, ...)
|
BeginFigureClosed | Marks the beginning of a closed figure.
|
LineTo | interior line segment point
Interior of a figure
|
QuadraticBezierPoint | interior quadratic bezier (degree=2, order=3) control point.
|
CubicBezierPoint | interior cubic bezier (degree=3, order=4) control point.
|
EndFigureOpen | End of an open figure (single stroke font, ...)
End of a figure
|
EndFigureClosed | End of a closed figure.
|
Error | Error of some sort.
|
◆ ON_OutlineFigurePoint() [1/2]
ON_OutlineFigurePoint::ON_OutlineFigurePoint |
( |
| ) |
|
|
default |
◆ ~ON_OutlineFigurePoint()
ON_OutlineFigurePoint::~ON_OutlineFigurePoint |
( |
| ) |
|
|
default |
◆ ON_OutlineFigurePoint() [2/2]
◆ ContourPointTypeFromUnsigned()
◆ FigureIndex()
ON__UINT16 ON_OutlineFigurePoint::FigureIndex |
( |
| ) |
const |
◆ IsBeginFigurePoint()
bool ON_OutlineFigurePoint::IsBeginFigurePoint |
( |
| ) |
const |
◆ IsBeginFigurePointType()
◆ IsEndFigurePoint()
bool ON_OutlineFigurePoint::IsEndFigurePoint |
( |
| ) |
const |
◆ IsEndFigurePointType()
◆ IsInteriorFigurePoint()
bool ON_OutlineFigurePoint::IsInteriorFigurePoint |
( |
| ) |
const |
◆ IsInteriorFigurePointType()
◆ IsOffFigure()
bool ON_OutlineFigurePoint::IsOffFigure |
( |
| ) |
const |
Returns: True if the point is in interior control point in bezier segment. False otherwise (the point is on at the start or end of a line or bezier segment or unset).
◆ IsOnFigure()
bool ON_OutlineFigurePoint::IsOnFigure |
( |
| ) |
const |
Returns: True if the point is on at the start or end of a line or bezier segment. False otherwise (the point is in interior control point in bezier segment or unset).
◆ operator=()
◆ Point()
const ON_2fPoint ON_OutlineFigurePoint::Point |
( |
| ) |
const |
◆ Point2d()
const ON_2dPoint ON_OutlineFigurePoint::Point2d |
( |
| ) |
const |
◆ Point2i()
const ON_2iPoint ON_OutlineFigurePoint::Point2i |
( |
| ) |
const |
Returns: Point rounded to nearest integer coordinates.
◆ Point2iCeil()
const ON_2iPoint ON_OutlineFigurePoint::Point2iCeil |
( |
| ) |
const |
Returns: Point rounded up (ceil) to integer coordinates.
◆ Point2iFloor()
const ON_2iPoint ON_OutlineFigurePoint::Point2iFloor |
( |
| ) |
const |
Returns: Point rounded down (floor) to integer coordinates.
◆ PointProximity()
◆ PointType()
◆ Error
◆ m_figure_index
ON__UINT16 ON_OutlineFigurePoint::m_figure_index = 0 |
0 = unset. The first figure in an outline has m_figure_index = 1.
◆ m_point
◆ m_point_proximity
◆ m_point_type
◆ Unset