Rhino C++ API
8.13
|
Class ON_PostEffectParams represents a collection of arbitrary post effect parameters. More...
#include <opennurbs_post_effects.h>
Public Member Functions | |
ON_PostEffectParams () | |
ON_PostEffectParams (const ON_PostEffectParams &) | |
ON_PostEffectParams (const ON_XMLNode &) | |
virtual | ~ON_PostEffectParams () |
virtual const ON_XMLParameters & | AsXMLParameters (void) const |
Get the parameter collection as an ON_XMLParameters object. More... | |
virtual ON__UINT32 | DataCRC (ON__UINT32 current_remainder) const |
Get a data CRC of the collection. More... | |
virtual void * | EVF (const wchar_t *func, void *data) |
Emergency virtual function for future expansion. More... | |
virtual bool | GetParam (const wchar_t *name, ON_XMLVariant &value_out) const |
Get a parameter from the collection by name. More... | |
bool | operator!= (const ON_PostEffectParams &)=delete |
const ON_PostEffectParams & | operator= (const ON_PostEffectParams &) |
bool | operator== (const ON_PostEffectParams &)=delete |
virtual bool | SetParam (const wchar_t *name, const ON_XMLVariant &value) |
Set a parameter to the collection by name. More... | |
Class ON_PostEffectParams represents a collection of arbitrary post effect parameters.
Copyright (c) 1993-2022 Robert McNeel & Associates. All rights reserved. OpenNURBS, Rhinoceros, and Rhino3D are registered trademarks of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete openNURBS copyright information see http://www.opennurbs.org.
ON_PostEffectParams::ON_PostEffectParams | ( | ) |
ON_PostEffectParams::ON_PostEffectParams | ( | const ON_XMLNode & | ) |
ON_PostEffectParams::ON_PostEffectParams | ( | const ON_PostEffectParams & | ) |
|
virtual |
|
virtual |
Get the parameter collection as an ON_XMLParameters object.
|
virtual |
Get a data CRC of the collection.
|
virtual |
Emergency virtual function for future expansion.
|
virtual |
Get a parameter from the collection by name.
|
delete |
const ON_PostEffectParams& ON_PostEffectParams::operator= | ( | const ON_PostEffectParams & | ) |
|
delete |
|
virtual |
Set a parameter to the collection by name.