#include <opennurbs_plus_implicitfn.h>
◆ ON_SphereSDF()
ON_SphereSDF::ON_SphereSDF |
( |
ON_3dPoint |
center, |
|
|
double |
radius |
|
) |
| |
|
inline |
◆ Evaluate()
Evaluate the signed distance function Parameters: p [in] - the point to evaluate the SDF at normal [out] - normal at the closest point on the SDF such that closestPt = pt - dist*normal/normal.Length() Returns: the distance between the closest point and the input point. Remarks:
- The returned distance can be ON_UNSET_VALUE when the SDF is unable to evaluate the distance
- The returned normal is not unitized and can have (almost) zero length.
You should account for both cases when using the SDF.
Implements ON_SignedDistanceFunction.
◆ center
◆ radius
const double ON_SphereSDF::radius |