#include <opennurbs_plus_squish.h>
|
| ON_SquisherImpl ()=default |
|
virtual | ~ON_SquisherImpl ()=default |
|
void | Dump (ON_TextLog &text_log) const |
|
virtual void | DumpEnergyDebugText (ON_TextLog &text_log) const =0 |
|
virtual int | GetAreaConstrainedTrianglesIndices (ON_SimpleArray< ON_MeshFace > *faces) const =0 |
|
virtual int | GetLengthConstrained2dLines (ON_SimpleArray< ON_Line > *edges) const =0 |
|
virtual int | GetLengthConstrained3dLines (ON_SimpleArray< ON_Line > *edges) const =0 |
|
virtual const ON_Mesh * | GetMesh2d () const =0 |
|
virtual const ON_Mesh * | GetMesh3d () const =0 |
|
virtual ON_Plane | GetPlane () const =0 |
|
virtual void | SaveOriginalObjectIdAndComponentIndex (const ON_UUID obj_id, const ON_COMPONENT_INDEX obj_ci, ON_Geometry *squished_geometry)=0 |
|
virtual ON_PolylineCurve * | SquishCurve (const ON_Curve &curve3d) const =0 |
|
virtual ON_Mesh * | SquishMesh (const ON_SquishParameters &squishParams, const ON_Mesh &mesh3d)=0 |
|
virtual ON_Mesh * | SquishMesh (const ON_SquishParameters &squishParams, const ON_Mesh &mesh3d, const ON_SimpleArray< const ON_Geometry * > *marks, ON_SimpleArray< ON_Geometry * > *squished_marks)=0 |
|
virtual bool | SquishPoint (ON_3dPoint point3d, ON_MESH_POINT &point2d) const =0 |
|
virtual ON_PointCloud * | SquishPointCloud (const ON_PointCloud &pc3) const =0 |
|
virtual ON_Brep * | SquishSurface (const ON_SquishParameters &squishParams, const ON_Surface &surface3d)=0 |
|
virtual ON_Brep * | SquishSurface (const ON_SquishParameters &squishParams, const ON_Surface &surface3d, const ON_SimpleArray< const ON_Geometry * > *marks, ON_SimpleArray< ON_Geometry * > *squished_marks)=0 |
|
virtual ON_TextDot * | SquishTextDot (const ON_TextDot &textDot) const =0 |
|
◆ ON_SquisherImpl()
ON_SquisherImpl::ON_SquisherImpl |
( |
| ) |
|
|
default |
◆ ~ON_SquisherImpl()
virtual ON_SquisherImpl::~ON_SquisherImpl |
( |
| ) |
|
|
virtualdefault |
◆ Dump()
void ON_SquisherImpl::Dump |
( |
ON_TextLog & |
text_log | ) |
const |
◆ DumpEnergyDebugText()
virtual void ON_SquisherImpl::DumpEnergyDebugText |
( |
ON_TextLog & |
text_log | ) |
const |
|
pure virtual |
◆ DumpSquishInfoText()
static void ON_SquisherImpl::DumpSquishInfoText |
( |
const ON_Geometry * |
squished_geometry, |
|
|
ON_TextLog & |
text_log, |
|
|
const wchar_t * |
objid_locale_str, |
|
|
const wchar_t * |
meshcount_locale_str |
|
) |
| |
|
static |
◆ GetAreaConstrainedTrianglesIndices()
◆ GetLengthConstrained2dLines()
◆ GetLengthConstrained3dLines()
◆ GetMesh2d()
virtual const ON_Mesh* ON_SquisherImpl::GetMesh2d |
( |
| ) |
const |
|
pure virtual |
◆ GetMesh3d()
virtual const ON_Mesh* ON_SquisherImpl::GetMesh3d |
( |
| ) |
const |
|
pure virtual |
◆ GetPlane()
virtual ON_Plane ON_SquisherImpl::GetPlane |
( |
| ) |
const |
|
pure virtual |
◆ Is2dPatternSquished()
static bool ON_SquisherImpl::Is2dPatternSquished |
( |
const ON_Geometry * |
geometry | ) |
|
|
static |
◆ SaveOriginalObjectIdAndComponentIndex()
◆ SquishBack2dMarks()
◆ SquishCurve()
◆ SquishMesh() [1/2]
◆ SquishMesh() [2/2]
◆ SquishPoint()
◆ SquishPointCloud()
◆ SquishSurface() [1/2]
◆ SquishSurface() [2/2]
◆ SquishTextDot()