#include <opennurbs_subd.h>
◆ ON_SubDComponentIterator() [1/4]
ON_SubDComponentIterator::ON_SubDComponentIterator |
( |
const class ON_SubD & |
subd | ) |
|
The ON_SubD member function ON_SubDComponentIterator ON_SubD::ComponentIterator(subd_level_index) is the best way to get a component iterator for a subd level.
◆ ON_SubDComponentIterator() [2/4]
ON_SubDComponentIterator::ON_SubDComponentIterator |
( |
const class ON_SubDRef & |
subd_ref | ) |
|
◆ ON_SubDComponentIterator() [3/4]
ON_SubDComponentIterator::ON_SubDComponentIterator |
( |
| ) |
|
|
default |
◆ ON_SubDComponentIterator() [4/4]
◆ CurrentComponent()
Returns: Current component;
◆ FirstComponent()
Description: Set the iterator to the beginning of the component list. Returns: First component in the list.
◆ LastComponent()
Description: Set the iterator to the end of the component list. Returns: Last component in the list.
◆ NextComponent()
Description: Returns the next component and increments the iterator. Returns: Next component. Remarks: operator++ and NextComponent() behave differently.
◆ operator++()
Description: Returns the current component and increment the iterator. Returns: Current component. Remarks: operator++ and NextComponent() behave differently.
◆ operator=()
◆ SubD()
const class ON_SubD& ON_SubDComponentIterator::SubD |
( |
| ) |
const |
|
inline |
Returns: The subD object for this iterator.
◆ SubDLevel()
unsigned int ON_SubDComponentIterator::SubDLevel |
( |
| ) |
const |
|
inline |
Returns: The subD level for this iterator.
◆ SubDRef()
const class ON_SubDRef& ON_SubDComponentIterator::SubDRef |
( |
| ) |
const |
|
inline |
◆ Empty