Rhino C++ API
8.13
|
#include <opennurbs_subd.h>
Public Member Functions | |
bool | BothAreNotNull () const |
bool | BothAreNull () const |
ON_SubDComponentPtr::Type | ComponentType () const |
const ON_SubDComponentPtr | First () const |
bool | FirstIsNotNull () const |
bool | FirstIsNull () const |
const ON_SubDComponentPtrPair | ReversedPair () const |
const ON_SubDComponentPtr | Second () const |
bool | SecondIsNotNull () const |
bool | SecondIsNull () const |
const ON_SubDComponentPtrPair | SwapPair () const |
Static Public Member Functions | |
static int | CompareComponent (const ON_SubDComponentPtrPair *lhs, const ON_SubDComponentPtrPair *rhs) |
static int | CompareComponentAndDirection (const ON_SubDComponentPtrPair *lhs, const ON_SubDComponentPtrPair *rhs) |
static int | CompareFirstPointer (const ON_SubDComponentPtrPair *lhs, const ON_SubDComponentPtrPair *rhs) |
static const ON_SubDComponentPtrPair | Create (ON_SubDComponentPtr first_ptr, ON_SubDComponentPtr second_ptr) |
Public Attributes | |
ON_SubDComponentPtr | m_pair [2] |
Static Public Attributes | |
static const ON_SubDComponentPtrPair | Null |
bool ON_SubDComponentPtrPair::BothAreNotNull | ( | ) | const |
Returns FirstIsNotNull() && SecondIsNotNull().
|
static |
Description: Dictionary order compare using ON_SubDComponentPtr::CompareComponent() on each element.
|
static |
Description: Dictionary order compare using ON_SubDComponentPtr::CompareComponentAndDirection() on each element.
|
static |
Description: Compare first pointer value.
ON_SubDComponentPtr::Type ON_SubDComponentPtrPair::ComponentType | ( | ) | const |
Returns: If both points have the same type, that type is returned. Otherwise ON_SubDComponentPtr::Type::Unset is returned.
|
static |
const ON_SubDComponentPtr ON_SubDComponentPtrPair::First | ( | ) | const |
Returns: First ON_SubDComponentPt in the pair.
bool ON_SubDComponentPtrPair::FirstIsNotNull | ( | ) | const |
Returns First().IsNotNull().
bool ON_SubDComponentPtrPair::FirstIsNull | ( | ) | const |
Returns FIrst().IsNull().
const ON_SubDComponentPtrPair ON_SubDComponentPtrPair::ReversedPair | ( | ) | const |
Returns: A pair with components reversed.
const ON_SubDComponentPtr ON_SubDComponentPtrPair::Second | ( | ) | const |
Returns: Second ON_SubDComponentPt in the pair.
bool ON_SubDComponentPtrPair::SecondIsNotNull | ( | ) | const |
Returns Second().IsNotNull().
bool ON_SubDComponentPtrPair::SecondIsNull | ( | ) | const |
Returns Second().IsNull().
const ON_SubDComponentPtrPair ON_SubDComponentPtrPair::SwapPair | ( | ) | const |
Returns: A pair with components in the opposite order
ON_SubDComponentPtr ON_SubDComponentPtrPair::m_pair[2] |
For performance reasons, m_ptrpair is not initialized and no constructors are declared or implemented. If you require initialization, then use x = ON_SubDComponentPtrPair::Null or x = ON_SubDComponentPtr::Create(first_ptr,second_ptr).
|
static |