#include <opennurbs_subd.h>
◆ ON_SubDFaceIdIterator() [1/4]
ON_SubDFaceIdIterator::ON_SubDFaceIdIterator |
( |
| ) |
|
|
default |
◆ ~ON_SubDFaceIdIterator()
ON_SubDFaceIdIterator::~ON_SubDFaceIdIterator |
( |
| ) |
|
|
default |
◆ ON_SubDFaceIdIterator() [2/4]
◆ ON_SubDFaceIdIterator() [3/4]
ON_SubDFaceIdIterator::ON_SubDFaceIdIterator |
( |
const ON_SubDRef & |
subd_ref | ) |
|
◆ ON_SubDFaceIdIterator() [4/4]
ON_SubDFaceIdIterator::ON_SubDFaceIdIterator |
( |
const ON_SubD & |
subd | ) |
|
◆ CurrentFace()
const ON_SubDFace* ON_SubDFaceIdIterator::CurrentFace |
( |
| ) |
const |
◆ FirstFace()
const ON_SubDFace* ON_SubDFaceIdIterator::FirstFace |
( |
| ) |
|
Description: In general, you want to use a ON_SubDFaceIterator to loop through SubD faces. This is a special tool for unusual sitiations when it is necessary to iteratate through every face on every level of a SubD in order of increasing m_id value. Returns: The face with the smallest id.
◆ FirstFaceOnLevel()
const ON_SubDFace* ON_SubDFaceIdIterator::FirstFaceOnLevel |
( |
unsigned int |
level_index | ) |
|
◆ NextFace()
Description: In general, you want to use a ON_SubDFaceIterator to loop through SubD faces. This is a special tool for unusual sitiations when it is necessary to iteratate through every face on every level of a SubD in order of increasing m_id value. Returns: The face in order of increasing id.
◆ NextFaceOnLevel()
const ON_SubDFace* ON_SubDFaceIdIterator::NextFaceOnLevel |
( |
unsigned int |
level_index | ) |
|
◆ operator=()
◆ ON_SubDHeap