Rhino C++ API
8.13
|
#include <opennurbs_subd.h>
Public Types | |
enum | MarkBitsFilter : unsigned char { MarkBitsFilter::None = 0, MarkBitsFilter::Equal = 1, MarkBitsFilter::NotEqual = 2 } |
Public Member Functions | |
ON_SubDRTreeVertexFinder ()=default | |
ON_SubDRTreeVertexFinder (const ON_SubDRTreeVertexFinder &)=default | |
~ON_SubDRTreeVertexFinder ()=default | |
ON_SubDRTreeVertexFinder & | operator= (const ON_SubDRTreeVertexFinder &)=default |
Static Public Member Functions | |
static bool | Callback (void *a_context, ON__INT_PTR a_id) |
static const ON_SubDRTreeVertexFinder | Create (const ON_3dPoint P) |
static const ON_SubDRTreeVertexFinder | Create (const ON_3dPoint P, bool bMarkFilter) |
static const ON_SubDRTreeVertexFinder | Create (const ON_3dPoint P, ON_SubDRTreeVertexFinder::MarkBitsFilter mark_bits_filter, ON__UINT8 mark_bits) |
Public Attributes | |
bool | m_bMarkFilter = false |
bool | m_bMarkFilterEnabled = false |
double | m_distance = ON_DBL_QNAN |
ON__UINT8 | m_mark_bits = 0 |
ON_SubDRTreeVertexFinder::MarkBitsFilter | m_mark_bits_filter = ON_SubDRTreeVertexFinder::MarkBitsFilter::None |
ON_3dPoint | m_P = ON_3dPoint::NanPoint |
const ON_SubDVertex * | m_v = nullptr |
Static Public Attributes | |
static const ON_SubDRTreeVertexFinder | Unset |
|
strong |
|
default |
|
default |
|
default |
|
static |
|
static |
|
static |
Parameters: bMarkFilter - [in] Vertices with Mark = bMarkFilter are eligible to be found. Vertices with Mark != bMarkFilter are ignored.
|
static |
|
default |
bool ON_SubDRTreeVertexFinder::m_bMarkFilter = false |
bool ON_SubDRTreeVertexFinder::m_bMarkFilterEnabled = false |
When m_bMarkFilterEnabled is true, then vertices with Mark() == m_bMarkFilter are eligible to be found and vertices with Mark() != m_bMarkFilter are ignored.
double ON_SubDRTreeVertexFinder::m_distance = ON_DBL_QNAN |
ON__UINT8 ON_SubDRTreeVertexFinder::m_mark_bits = 0 |
ON_SubDRTreeVertexFinder::MarkBitsFilter ON_SubDRTreeVertexFinder::m_mark_bits_filter = ON_SubDRTreeVertexFinder::MarkBitsFilter::None |
ON_3dPoint ON_SubDRTreeVertexFinder::m_P = ON_3dPoint::NanPoint |
const ON_SubDVertex* ON_SubDRTreeVertexFinder::m_v = nullptr |
|
static |