#include <opennurbs_subd.h>
◆ ON_SubDVertexIdIterator() [1/4]
ON_SubDVertexIdIterator::ON_SubDVertexIdIterator |
( |
| ) |
|
|
default |
◆ ~ON_SubDVertexIdIterator()
ON_SubDVertexIdIterator::~ON_SubDVertexIdIterator |
( |
| ) |
|
|
default |
◆ ON_SubDVertexIdIterator() [2/4]
◆ ON_SubDVertexIdIterator() [3/4]
ON_SubDVertexIdIterator::ON_SubDVertexIdIterator |
( |
const ON_SubDRef & |
subd_ref | ) |
|
◆ ON_SubDVertexIdIterator() [4/4]
ON_SubDVertexIdIterator::ON_SubDVertexIdIterator |
( |
const ON_SubD & |
subd | ) |
|
◆ CurrentVertex()
const ON_SubDVertex* ON_SubDVertexIdIterator::CurrentVertex |
( |
| ) |
const |
◆ FirstVertex()
Description: In general, you want to use a ON_SubDVertexIterator to loop through SubD vertices. This is a special tool for unusual sitiations when it is necessary to iteratate through every vertex on every level of a SubD in order of increasing m_id value. Returns: The vertex with the smallest id.
◆ FirstVertexOnLevel()
const ON_SubDVertex* ON_SubDVertexIdIterator::FirstVertexOnLevel |
( |
unsigned int |
level_index | ) |
|
◆ NextVertex()
Description: In general, you want to use a ON_SubDVertexIterator to loop through SubD vertices. This is a special tool for unusual sitiations when it is necessary to iteratate through every vertex on every level of a SubD in order of increasing m_id value. Returns: The vertex in order of increasing id.
◆ NextVertexOnLevel()
const ON_SubDVertex* ON_SubDVertexIdIterator::NextVertexOnLevel |
( |
unsigned int |
level_index | ) |
|
◆ operator=()
◆ ON_SubDHeap