Rhino C++ API
8.13
|
Converts wchar_t characters to Unicode codepoints. More...
#include <opennurbs_textiterator.h>
Public Member Functions | |
ON_TextIterator (const ON_TextIterator &)=default | |
ON_TextIterator (const ON_wString &str) | |
ON_TextIterator (const wchar_t *str, size_t length) | |
~ON_TextIterator ()=default | |
bool | AtBackslashTic () const |
bool | Back () |
move position back and return current codepoint after moving back More... | |
ON_TextIterator & | operator= (const ON_TextIterator &)=default |
bool | PeekCodePoint (ON__UINT32 &unicode_code_point) const |
bool | ReadCharValue (unsigned char &c) |
bool | ReadCodePoint (ON__UINT32 &unicode_code_point) |
bool | Step () |
Converts wchar_t characters to Unicode codepoints.
ON_TextIterator::ON_TextIterator | ( | const ON_wString & | str | ) |
ON_TextIterator::ON_TextIterator | ( | const wchar_t * | str, |
size_t | length | ||
) |
|
default |
|
default |
bool ON_TextIterator::AtBackslashTic | ( | ) | const |
bool ON_TextIterator::Back | ( | ) |
move position back and return current codepoint after moving back
|
default |
bool ON_TextIterator::PeekCodePoint | ( | ON__UINT32 & | unicode_code_point | ) | const |
Parameters: unicode_code_point - [out] current unicode code point returned here. 0 = end of string Returns: true if returned unicode_code_point is not zero
bool ON_TextIterator::ReadCharValue | ( | unsigned char & | c | ) |
bool ON_TextIterator::ReadCodePoint | ( | ON__UINT32 & | unicode_code_point | ) |
Description: Gets the current unicode code point and calls Step() to advance the text iterator by one code point. Parameters: unicode_code_point - [out] current unicode code point returned here. 0 = end of string Returns: true if returned unicode_code_point is not zero
bool ON_TextIterator::Step | ( | ) |
Get the next UNICODE code point encoded in m_text beginning at m_text[m_next_text_ci]; Save this code point in m_cur_codepoint. Advance m_next_text_ci.