Rhino C++ API
8.13
|
#include <opennurbs_file_utilities.h>
Public Types | |
enum | Modes { Modes::Read, Modes::Write } |
enum | Types { Types::Unknown, Types::UTF8, Types::UTF16 } |
Public Member Functions | |
ON_UnicodeTextFile (const ON_UnicodeTextFile &)=delete | |
ON_UnicodeTextFile (Types type=Types::Unknown) | |
~ON_UnicodeTextFile () | |
bool | Close (void) |
bool | Open (const wchar_t *filename, Modes mode) |
const ON_UnicodeTextFile & | operator= (const ON_UnicodeTextFile &)=delete |
bool | ReadString (ON_wString &s) |
bool | WriteString (const wchar_t *s) |
|
strong |
|
strong |
ON_UnicodeTextFile::ON_UnicodeTextFile | ( | Types | type = Types::Unknown | ) |
ON_UnicodeTextFile::~ON_UnicodeTextFile | ( | ) |
|
delete |
bool ON_UnicodeTextFile::Close | ( | void | ) |
bool ON_UnicodeTextFile::Open | ( | const wchar_t * | filename, |
Modes | mode | ||
) |
|
delete |
bool ON_UnicodeTextFile::ReadString | ( | ON_wString & | s | ) |
bool ON_UnicodeTextFile::WriteString | ( | const wchar_t * | s | ) |