#include <opennurbs_compstat.h>
◆ ON_UniqueTester() [1/2]
ON_UniqueTester::ON_UniqueTester |
( |
| ) |
|
|
default |
◆ ~ON_UniqueTester()
ON_UniqueTester::~ON_UniqueTester |
( |
| ) |
|
◆ ON_UniqueTester() [2/2]
◆ AddToList()
bool ON_UniqueTester::AddToList |
( |
ON__UINT_PTR |
x | ) |
|
Description: If p is not in the list, it is added. Returns: True if p is not in the list and was added. False if p was already in the list.
◆ ClearList()
void ON_UniqueTester::ClearList |
( |
| ) |
|
◆ Count()
unsigned int ON_UniqueTester::Count |
( |
| ) |
const |
◆ ExpertAddNewToList()
void ON_UniqueTester::ExpertAddNewToList |
( |
ON__UINT_PTR |
x | ) |
|
Description: Add x to the list. The expert caller is certain that x is not already in the list. For large lists, using this function when appropriate, can result in substantial speed improvements. Parameters: x - [in] A value that is known to not be in the list.
◆ InList()
bool ON_UniqueTester::InList |
( |
ON__UINT_PTR |
x | ) |
const |
Description: If p is not in the list, it is added. Returns: True if p is in the list.
◆ operator=()