Rhino C++ API  8.7
Public Member Functions | Public Attributes | List of all members
ON_XMLNode::CharacterCounts Class Reference

#include <opennurbs_xml.h>

Public Member Functions

void operator+= (const CharacterCounts &cw)
 

Public Attributes

ON__UINT32 _logical = 0
 
ON__UINT32 _physical = 0
 
ON__UINT64 _reserved = 0
 

Member Function Documentation

◆ operator+=()

void ON_XMLNode::CharacterCounts::operator+= ( const CharacterCounts cw)

Member Data Documentation

◆ _logical

ON__UINT32 ON_XMLNode::CharacterCounts::_logical = 0

Number of characters that would have been written if the buffer was big enough. This value does not include the terminator.

◆ _physical

ON__UINT32 ON_XMLNode::CharacterCounts::_physical = 0

Number of characters that were physically written. Always zero if max_chars is zero. It is otherwise usually the same as m_logical, but less when the buffer is too small. This value does not include the terminator.

◆ _reserved

ON__UINT64 ON_XMLNode::CharacterCounts::_reserved = 0