#include <opennurbs_xml.h>
◆ ON_XMLProperty() [1/4]
ON_XMLProperty::ON_XMLProperty |
( |
| ) |
|
◆ ON_XMLProperty() [2/4]
◆ ON_XMLProperty() [3/4]
◆ ON_XMLProperty() [4/4]
◆ ~ON_XMLProperty()
virtual ON_XMLProperty::~ON_XMLProperty |
( |
| ) |
|
|
virtual |
◆ DataCRC()
◆ EVF()
virtual void* ON_XMLProperty::EVF |
( |
const wchar_t * |
func, |
|
|
void * |
data |
|
) |
| |
|
virtual |
◆ GetNonConstValue()
◆ GetValue()
virtual const ON_XMLVariant& ON_XMLProperty::GetValue |
( |
void |
| ) |
const |
|
virtual |
◆ IsDefaultProperty()
virtual bool ON_XMLProperty::IsDefaultProperty |
( |
void |
| ) |
const |
|
virtual |
◆ Name()
virtual const ON_wString& ON_XMLProperty::Name |
( |
void |
| ) |
const |
|
virtual |
◆ Next()
◆ operator<()
◆ operator=()
◆ SetHugeStringValue()
virtual void ON_XMLProperty::SetHugeStringValue |
( |
const ON_wString & |
s | ) |
|
|
virtual |
◆ SetName()
virtual void ON_XMLProperty::SetName |
( |
const wchar_t * |
name | ) |
|
|
virtual |
◆ SetValue()
virtual void ON_XMLProperty::SetValue |
( |
const ON_XMLVariant & |
value | ) |
|
|
virtual |
◆ ON_XMLNode
◆ ON_XMLNodePrivate
friend class ON_XMLNodePrivate |
|
friend |
◆ ON_XMLPropertyPrivate
friend class ON_XMLPropertyPrivate |
|
friend |