Rhino C++ API  8.6
Public Member Functions | Friends | List of all members
ON_XMeshFF Class Reference

#include <opennurbs_plus_mesh_intersection.h>

Public Member Functions

 ON_XMeshFF (ON_XMeshFace *pF0, ON_XMeshFace *pF1)
 
 ~ON_XMeshFF ()
 
void AddEvent (ON_XMeshEvent *pX)
 
ON_XMeshEventEvent (int id)
 Gives m_X[id]. No range checking. More...
 
int EventCount () const
 
bool FacesMatch (ON_XMeshFace *pF0, const ON_XMeshFace *pF1) const
 
bool HasComponentEvent (const ON_XMeshComponent *pC, int side) const
 
bool HasEvent (const ON_XMeshEvent *pX) const
 
void RemoveEvent (const ON_XMeshEvent *pX)
 

Friends

class ON_XMeshFace
 
class ON_XMeshFFIterator
 
class ON_XMeshFFPool
 
class ON_XMeshIntersector
 

Constructor & Destructor Documentation

◆ ON_XMeshFF()

ON_XMeshFF::ON_XMeshFF ( ON_XMeshFace pF0,
ON_XMeshFace pF1 
)

◆ ~ON_XMeshFF()

ON_XMeshFF::~ON_XMeshFF ( )

Member Function Documentation

◆ AddEvent()

void ON_XMeshFF::AddEvent ( ON_XMeshEvent pX)

◆ Event()

ON_XMeshEvent* ON_XMeshFF::Event ( int  id)

Gives m_X[id]. No range checking.

◆ EventCount()

int ON_XMeshFF::EventCount ( ) const

◆ FacesMatch()

bool ON_XMeshFF::FacesMatch ( ON_XMeshFace pF0,
const ON_XMeshFace pF1 
) const

◆ HasComponentEvent()

bool ON_XMeshFF::HasComponentEvent ( const ON_XMeshComponent pC,
int  side 
) const

◆ HasEvent()

bool ON_XMeshFF::HasEvent ( const ON_XMeshEvent pX) const

◆ RemoveEvent()

void ON_XMeshFF::RemoveEvent ( const ON_XMeshEvent pX)

Friends And Related Function Documentation

◆ ON_XMeshFace

friend class ON_XMeshFace
friend

◆ ON_XMeshFFIterator

friend class ON_XMeshFFIterator
friend

◆ ON_XMeshFFPool

friend class ON_XMeshFFPool
friend

◆ ON_XMeshIntersector

friend class ON_XMeshIntersector
friend