#include <opennurbs_extensions.h>
◆ ONX_ModelComponentIterator() [1/3]
ONX_ModelComponentIterator::ONX_ModelComponentIterator |
( |
| ) |
|
|
default |
◆ ~ONX_ModelComponentIterator()
ONX_ModelComponentIterator::~ONX_ModelComponentIterator |
( |
| ) |
|
|
default |
◆ ONX_ModelComponentIterator() [2/3]
◆ ONX_ModelComponentIterator() [3/3]
◆ ActiveComponentCount()
unsigned int ONX_ModelComponentIterator::ActiveComponentCount |
( |
| ) |
const |
Returns: Number of active components in the current model. Remarks: If the model is modified during iteration, this value will changes.
◆ CurrentComponent()
◆ CurrentComponentReference()
◆ CurrentComponentWeakReference()
◆ FirstComponent()
Use these with caution unless it is clear you are the only thread with references to the model and the iterator.
◆ FirstComponentReference()
◆ FirstComponentWeakReference()
◆ LastComponent()
◆ LastComponentReference()
◆ LastComponentWeakReference()
◆ Model()
const ONX_Model* ONX_ModelComponentIterator::Model |
( |
| ) |
const |
◆ NextComponent()
◆ NextComponentReference()
◆ NextComponentWeakReference()
◆ operator=()
◆ PreviousComponent()
◆ PreviousComponentReference()
◆ PreviousComponentWeakReference()