Rhino C++ API  8.7
Public Member Functions | List of all members
RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance::IGeometry Class Referenceabstract

The IGeometry is class that collects all of the pure geometry information together for an instance. Essentially - the mesh/primitive along with the caching information for the display and an Id to differentiate meshes from each other without having to check their CRC. More...

#include <IRhRdkCustomRenderMeshes.h>

Public Member Functions

virtual ~IGeometry (void)
 
virtual std::shared_ptr< CRhinoCacheHandleCacheHandle (void) const =0
 The cache handle for the mesh - used by the display to manage the VBOs. More...
 
virtual ON_UUID CacheHandleId (void) const =0
 An ID which uniquely identifies a shared mesh. If the ID is the same for two separate geometry objects, the mesh or primitive produced by them will be considered the same - unless the ID is ON_nil_uuid in which case each one will be treated as though not shared. More...
 
virtual std::shared_ptr< const MappingChannelsMappingChannels (void) const =0
 Per mesh mapping channels. If not supplied, then assume a single surface mapping channel. May be overridden by the per-instance mapping channels. More...
 
virtual std::shared_ptr< const ON_MeshMesh (void) const =0
 Returns the mesh associated with this geometry. More...
 

Detailed Description

The IGeometry is class that collects all of the pure geometry information together for an instance. Essentially - the mesh/primitive along with the caching information for the display and an Id to differentiate meshes from each other without having to check their CRC.

Constructor & Destructor Documentation

◆ ~IGeometry()

virtual RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance::IGeometry::~IGeometry ( void  )
inlinevirtual

Member Function Documentation

◆ CacheHandle()

virtual std::shared_ptr<CRhinoCacheHandle> RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance::IGeometry::CacheHandle ( void  ) const
pure virtual

The cache handle for the mesh - used by the display to manage the VBOs.

Returns

◆ CacheHandleId()

virtual ON_UUID RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance::IGeometry::CacheHandleId ( void  ) const
pure virtual

An ID which uniquely identifies a shared mesh. If the ID is the same for two separate geometry objects, the mesh or primitive produced by them will be considered the same - unless the ID is ON_nil_uuid in which case each one will be treated as though not shared.

Returns

◆ MappingChannels()

virtual std::shared_ptr<const MappingChannels> RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance::IGeometry::MappingChannels ( void  ) const
pure virtual

Per mesh mapping channels. If not supplied, then assume a single surface mapping channel. May be overridden by the per-instance mapping channels.

Returns
The mapping channels for this mesh.

◆ Mesh()

virtual std::shared_ptr<const ON_Mesh> RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance::IGeometry::Mesh ( void  ) const
pure virtual

Returns the mesh associated with this geometry.

Returns
A shared pointer to the mesh.