Rhino C++ API  8.6
Classes | Public Member Functions | List of all members
RhRdk::CustomRenderMeshes::IRenderMeshes::ProviderTracking::ITracker Class Referenceabstract

The per-document primitive cache for MeshProviders. ITracker is basically a hash map of shared_ptr<const IRenderMeshes> with the key being the ObjectId. More...

#include <IRhRdkCustomRenderMeshes.h>

Classes

class  IRecord
 Each tracker record is basically the entry in the map - so it's an IRenderMeshes object More...
 

Public Member Functions

virtual ~ITracker ()
 
virtual void * EVF (const wchar_t *wszFunc, void *pv)=0
 Emergency virtual function for future expansion More...
 
virtual const IRecordRecord (const ObjectId &id) const =0
 Access the record for a specific ObjectId More...
 
virtual void Set (std::shared_ptr< const IRenderMeshes > prims)=0
 Adds a new set of primitives to the map. More...
 

Detailed Description

The per-document primitive cache for MeshProviders. ITracker is basically a hash map of shared_ptr<const IRenderMeshes> with the key being the ObjectId.

Constructor & Destructor Documentation

◆ ~ITracker()

virtual RhRdk::CustomRenderMeshes::IRenderMeshes::ProviderTracking::ITracker::~ITracker ( )
inlinevirtual

Member Function Documentation

◆ EVF()

virtual void* RhRdk::CustomRenderMeshes::IRenderMeshes::ProviderTracking::ITracker::EVF ( const wchar_t *  wszFunc,
void *  pv 
)
pure virtual

Emergency virtual function for future expansion

Parameters
wszFuncThe named function
pvPrivate data
Returns
Private data in the form of a void*

◆ Record()

virtual const IRecord* RhRdk::CustomRenderMeshes::IRenderMeshes::ProviderTracking::ITracker::Record ( const ObjectId id) const
pure virtual

Access the record for a specific ObjectId

Parameters
idThe ObjectId for these primitives.
Returns
The record in the cache containing the primitives.

◆ Set()

virtual void RhRdk::CustomRenderMeshes::IRenderMeshes::ProviderTracking::ITracker::Set ( std::shared_ptr< const IRenderMeshes prims)
pure virtual

Adds a new set of primitives to the map.

Parameters
primsThe primitives to be added. The prims must return a correct ObjectId and Hash for the cache to work correctly.