Rhino C++ API  8.7
Public Member Functions | List of all members
RhRdk::CustomRenderMeshes::IRenderMeshes::ProviderTracking::ITracker::IRecord Class Referenceabstract

Each tracker record is basically the entry in the map - so it's an IRenderMeshes object More...

#include <IRhRdkCustomRenderMeshes.h>

Public Member Functions

virtual ~IRecord ()
 
virtual void * EVF (const wchar_t *wszFunc, void *pv)=0
 Emergency virtual function for future expansion More...
 
virtual ON__UINT32 Hash (void) const =0
 Quick access to the hash for the primitives. More...
 
virtual std::shared_ptr< const IRenderMeshesPrimitives (void) const =0
 A shared pointer to the IRenderMeshes stored in the map More...
 

Detailed Description

Each tracker record is basically the entry in the map - so it's an IRenderMeshes object

Constructor & Destructor Documentation

◆ ~IRecord()

virtual RhRdk::CustomRenderMeshes::IRenderMeshes::ProviderTracking::ITracker::IRecord::~IRecord ( )
inlinevirtual

Member Function Documentation

◆ EVF()

virtual void* RhRdk::CustomRenderMeshes::IRenderMeshes::ProviderTracking::ITracker::IRecord::EVF ( const wchar_t *  wszFunc,
void *  pv 
)
pure virtual

Emergency virtual function for future expansion

Parameters
wszFuncThe named function
pvPrivate data
Returns
Private data in the form of a void*

◆ Hash()

virtual ON__UINT32 RhRdk::CustomRenderMeshes::IRenderMeshes::ProviderTracking::ITracker::IRecord::Hash ( void  ) const
pure virtual

Quick access to the hash for the primitives.

Returns
The render hash

◆ Primitives()

virtual std::shared_ptr<const IRenderMeshes> RhRdk::CustomRenderMeshes::IRenderMeshes::ProviderTracking::ITracker::IRecord::Primitives ( void  ) const
pure virtual

A shared pointer to the IRenderMeshes stored in the map

Returns
A shared pointer to the IRenderMeshes stored in the map