Rhino C++ API  8.5
Public Attributes | List of all members
ON_RTreeNode Struct Reference

#include <opennurbs_rtree.h>

Public Attributes

ON_RTreeBranch m_branch [ON_RTree_MAX_NODE_COUNT]
 
int m_count
 
int m_level
 m_level must be a signed int to insure signed compares work correctly More...
 

Detailed Description

The ON_RTreeNode is used at root, branch and leaf nodes. When m_level > 0, the node is a branch. When m_level = 0, the node is a leaf.

Member Data Documentation

◆ m_branch

ON_RTreeBranch ON_RTreeNode::m_branch[ON_RTree_MAX_NODE_COUNT]

◆ m_count

int ON_RTreeNode::m_count

The m_branch[] array contains m_count elements 0 <= m_count <= ON_RTree_MAX_NODE_COUNT m_count must be a signed int to insure signed compares work correctly

◆ m_level

int ON_RTreeNode::m_level

m_level must be a signed int to insure signed compares work correctly

=0 at leaf nodes, > 0 at branch nodes