Rhino C++ API  8.6
Public Attributes | List of all members
ON_RTreeSearchResult Struct Reference

#include <opennurbs_rtree.h>

Public Attributes

int m_capacity
 m_id[] array capacity (search terminates when m_count == m_capacity) More...
 
int m_count
 number of elements in m_id[] More...
 
ON__INT_PTR * m_id
 m_id[] = array of search results. More...
 

Member Data Documentation

◆ m_capacity

int ON_RTreeSearchResult::m_capacity

m_id[] array capacity (search terminates when m_count == m_capacity)

◆ m_count

int ON_RTreeSearchResult::m_count

number of elements in m_id[]

◆ m_id

ON__INT_PTR* ON_RTreeSearchResult::m_id

m_id[] = array of search results.