Rhino C++ API  8.6
Public Member Functions | Public Attributes | List of all members
ON_SerialNumberMap::SN_ELEMENT Struct Reference

#include <opennurbs_lookup.h>

Public Member Functions

void Dump (ON_TextLog &) const
 

Public Attributes

ON_UUID m_id
 
ON__UINT8 m_id_active
 1 = id is active More...
 
ON__UINT32 m_id_crc32
 id hash = IdCRC(id) More...
 
struct SN_ELEMENTm_next
 id hash table linked list More...
 
ON__UINT8 m_reserved1
 
ON__UINT8 m_reserved2
 
ON__UINT64 m_sn
 
ON__UINT8 m_sn_active
 1 = serial number is active More...
 
struct MAP_VALUE m_value
 

Member Function Documentation

◆ Dump()

void ON_SerialNumberMap::SN_ELEMENT::Dump ( ON_TextLog ) const

Member Data Documentation

◆ m_id

ON_UUID ON_SerialNumberMap::SN_ELEMENT::m_id

ID

◆ m_id_active

ON__UINT8 ON_SerialNumberMap::SN_ELEMENT::m_id_active

1 = id is active

◆ m_id_crc32

ON__UINT32 ON_SerialNumberMap::SN_ELEMENT::m_id_crc32

id hash = IdCRC(id)

◆ m_next

struct SN_ELEMENT* ON_SerialNumberMap::SN_ELEMENT::m_next

id hash table linked list

◆ m_reserved1

ON__UINT8 ON_SerialNumberMap::SN_ELEMENT::m_reserved1

◆ m_reserved2

ON__UINT8 ON_SerialNumberMap::SN_ELEMENT::m_reserved2

◆ m_sn

ON__UINT64 ON_SerialNumberMap::SN_ELEMENT::m_sn

Serial number:

◆ m_sn_active

ON__UINT8 ON_SerialNumberMap::SN_ELEMENT::m_sn_active

1 = serial number is active

Status flags:

If m_id_active is 1, then m_sn_active must be 1. If m_sn_active = 1, then m_id_active can be 0 or 1.

◆ m_value

struct MAP_VALUE ON_SerialNumberMap::SN_ELEMENT::m_value

User information:

ON_SerialNumberMap does not use the m_value field. When a new element is added, m_value is memset to zero. Other than that, m_value is not changed by this class. The location of m_value in memory, (&m_value) may change at any time.