Rhino C++ API  8.6
Public Attributes | List of all members
ON_WindowsBITMAPINFOHEADER Struct Reference

#include <opennurbs_bitmap.h>

Public Attributes

unsigned short biBitCount
 
unsigned int biClrImportant
 DWORD. More...
 
unsigned int biClrUsed
 
unsigned int biCompression
 
int biHeight
 
unsigned short biPlanes
 
unsigned int biSize
 DWORD = sizeof(BITMAPINFOHEADER) More...
 
unsigned int biSizeImage
 DWORD = bytes in image. More...
 
int biWidth
 LONG = width (in pixels) of (decompressed) bitmap. More...
 
int biXPelsPerMeter
 LONG. More...
 
int biYPelsPerMeter
 LONG. More...
 

Detailed Description

Mimics Windows BITMAPINFOHEADER structure. For details searh for "BITMAPINFOHEADER" at http://msdn.microsoft.com/default.asp Windows sizeof(BITMAPINFOHEADER) = 80.

Member Data Documentation

◆ biBitCount

unsigned short ON_WindowsBITMAPINFOHEADER::biBitCount

WORD = bits per pixel (0,1,4,8,16,24,32 are valid) 1 See http://msdn.microsoft.com/default.asp
4 See http://msdn.microsoft.com/default.asp
8 The bitmap has a maximum of 256 colors, and the bmiColors member contains up to 256 entries. In this case, each byte in the array represents a single pixel. 16 See http://msdn.microsoft.com/default.asp
24 If biClrUsed=0 and biCompression=BI_RGB(0), then each 3-byte triplet in the bitmap array represents the relative intensities of blue, green, and red, respectively, for a pixel. For other possibilities, see http://msdn.microsoft.com/default.asp
32 If biClrUsed=0 and biCompression=BI_RGB(0), then each 4-byte DWORD in the bitmap array represents the relative intensities of blue, green, and red, respectively, for a pixel. The high byte in each DWORD is not used.
If biClrUsed=3, biCompression=BITFIELDS(3), biColors[0] = red mask (0x00FF0000), biColors[1] = green mask (0x0000FF00), and biColors[2] = blue mask (0x000000FF), then tese masks are used with each 4-byte DWORD in the bitmap array to determine the pixel's relative intensities. ///<
For other possibilities, see http://msdn.microsoft.com/default.asp

◆ biClrImportant

unsigned int ON_WindowsBITMAPINFOHEADER::biClrImportant

DWORD.

◆ biClrUsed

unsigned int ON_WindowsBITMAPINFOHEADER::biClrUsed

DWORD = 0 or true length of bmiColors[] array. If 0, then the value of biBitCount determines the length of the bmiColors[] array.

◆ biCompression

unsigned int ON_WindowsBITMAPINFOHEADER::biCompression

DWORD Currently, Windows defines the following types of compression. =0 BI_RGB (no compression) =1 BI_RLE8 (run length encoded used for 8 bpp) =2 BI_RLE4 (run length encoded used for 4 bpp) =3 BI_BITFIELDS Specifies that the bitmap is not compressed and that the color table consists of three DWORD color masks that specify the red, green, and blue components, respectively, of each pixel. This is valid when used with 16- and 32-bit-per-pixel bitmaps. =4 BI_JPEG (not supported in Win 95/NT4)

◆ biHeight

int ON_WindowsBITMAPINFOHEADER::biHeight

LONG = height (in pixels) of (decompressed) bitmap >0 means it's a bottom-up bitmap with origin in the lower left corner. <0 means it's a top-down bitmap with origin in the upper left corner.

◆ biPlanes

unsigned short ON_WindowsBITMAPINFOHEADER::biPlanes

WORD = number of planes (always 1 in current Windows versions)

◆ biSize

unsigned int ON_WindowsBITMAPINFOHEADER::biSize

DWORD = sizeof(BITMAPINFOHEADER)

◆ biSizeImage

unsigned int ON_WindowsBITMAPINFOHEADER::biSizeImage

DWORD = bytes in image.

◆ biWidth

int ON_WindowsBITMAPINFOHEADER::biWidth

LONG = width (in pixels) of (decompressed) bitmap.

◆ biXPelsPerMeter

int ON_WindowsBITMAPINFOHEADER::biXPelsPerMeter

LONG.

◆ biYPelsPerMeter

int ON_WindowsBITMAPINFOHEADER::biYPelsPerMeter

LONG.